micctrl bugs in --addnfs and --pm

micctrl bugs in --addnfs and --pm

I found two bugs in micctrl commands:

1. micctrl --addnfs=<nfs server>:///nfs/a --dir=/opt/a mic1

This command can only set nfs server to be the mic host node. That means specifying <nfs server> for --addnfs does not work.

2. micctrl --pm=set  --cpufreq=off

This command cannot set cpufreq to be 'off'

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Then I found I could not set the attribute to 'on' after setting to 'off'.

Original state in mic0.conf

    PowerManagement "cpufreq_on;corec6_off;pc3_off;pc6_off"

I run command to turn them on

    # micctrl --pm=set --corec6=on --pc3=on --pc6=on mic0

Then in mic0.conf, did not see any change

    PowerManagement "cpufreq_on;corec6_off;pc3_off;pc6_off"

 

Was I using micctrl command in incorrect parameter formats? Or it's a bug of micctrl command?

Hi Xiao, 

It seems that your usage of the power management options is correct and I have been able to reproduce the issue. On your behalf, I have filed a bug against micctrl for the power management options. The reference number for the issue is 6000034235.

Thanks, 

Sumedh

Leave a Comment

Please sign in to add a comment. Not a member? Join today