micflash hangs of Ubuntu 12.04

micflash hangs of Ubuntu 12.04

With slight modification to the Makefiles, I was able to compile most of the MPSS 3.1.1 and 3.1.2 components from the source o
n Ubuntu 12.04 and have them working. However, micflash -ubpdate  is giving me problems, so does micflash -getversion. The mic
flash doesn't seem to be able to read the flash from the mic card. Below are my steps:

micctrl -rw
micctrl -s
 Shows the ready state for both the devices

micflash -vv -update -device all

Gives the following: \
mic0: Read Flash: 0%
mic0: Update Flash: 0%
mic0: Update SMC: 0%
mic0: Update SMC boot-loader: 0%
mic1: Read Flash: 0%
mic1: Update Flash: 0%
mic1: Update SMC: 0%
mic1: Update SMC boot-loader: 0%

As you can see from above, the flash from the cards can't be read. I kill the micflash processes and check the mic state:

pkill -9 micflash
micctrl -s
mic0: boot failed
mic1: boot failed

Power off-and-on didn't help.  I'll appreciate recommendations from the MIC experts. The mpssinfo and debug tar ball are attached.

 

 

 

 

 

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I haven't digested all the information in your micdebug file yet, but I did notice that your coprocessors are B1 stepping. I don't know if you should be using the 

sudo /usr/bin/micflash -update -device all -smcbootloader

or 

sudo /usr/bin/micflash -update -device all

command. Knowing what version of SMC your card came with would help.

I think I would have started by recompiling just the kernel module rather than everything, so that I had fewer unknowns in the install. From the mpssd log, it looks like some of your files might not have been in the expected directories after your install..

It looks like the cards boot correctly if you start the mpss service although it didn't work on the first try. Did you move some files around between attempts? Had you already successfully booted the cards at least once when you tried to run the micflash command? The cards need to be in the ready state, not booted, when you run micflash -update but you can't read the flash and SMC versions numbers off the cards unless they can boot.

What command did you use to try to find the current version number of the flash? The mpssinfo output will only tell you the flash and SMC versions when the card is booted. I usually use micinfo rather than mpssinfo, because micinfo tells you when it can't read the version number, while mpssinfo just pretends the information doesn't exist. Also, the fact that the mpssinfo command could not give you the MPSS version number again implies that some of the files did not install in the correct places.

Francis - Many thanks for your prompt response to my posting.

I've tried micflash -update with -smcbootloader and without. In both the cases, micflash hanged. While running the flash update, I've executed strace on the three running micflash processes - one master and the two children for each card.  The children micflash processes hanged at reading /sys/class/mic/micX/state, "boot failed" - see the attached strace.txt. The cards were in "ready" state, according micctrl -s. The mpssd was not running. It looks like micflash was trying to bring the cards into the boot state for some reason.

When I did  compilation of mpss-3.1.2, specifically, libscif-3.1.2, mpss-micdaemon-3.1.2, mpss-micmgmt-3.1.2, I've specified installation directory /usr/local/sbin for the binaries, and /usr/local/lib for the shared libraries.

The cards booted up fine. You can see the attached mpssd.log and miccheck.txt. From the latter you can see that I got stuck with the old flash image on the card, '386'. Btw, I was able to run openmp test simulations with MPSS-3.1, which comes with flash image  '386'. However, micflash -getversion also failed  on MPSS-3.1.

I've run micinfo when the cards have booted and mpssd was running. The output is in the attached  micinfo.txt.

Do you recommend me to recompile mic.ko?

 

 

Attachments: 

AttachmentSize
Downloadtext/plain miccheck.txt992 bytes
Downloadtext/plain strace_0.txt518 bytes
Downloadtext/plain micinfo_2.txt2.49 KB
Downloadapplication/octet-stream mpssd.log3.05 KB

The MPSS relies on some things being installed in specific location. I notice that miccheck thinks the current version of flash should be 0. That says to me that the update file isn't where it should be. By default it installs in /usr/share/mpss/flash/ (and micflash installs in /usr/bin). I don't have a list of what cannot be moved and what can. My suggestion is - uninstall all the MPSS pieces, untar the MPSS release into a new location so you are starting fresh, recompile the mic.ko kernel module (and only that) following the directions in the User's Guide (section 9.1 in the latest version - it was section 8.1 in the previous version), then install following the directions in the readme-en.txt. If this works, then you will need to rebuild OFED following the directions in the User's Guide (section 9.2, then section 2.*), if you want to use your InfiniBand with the coprocessor. Most of the other parts of the MPSS probably don't need to be recompiled just because you are using Ubuntu. If you find that something does seem to need recompiling, hopefully it can be dealt with after the cards are updated and working.

For additional information, there is a page on flash troubleshooting in http://software.intel.com/en-us/forums/topic/494772. Even if the flash update file is in the right place, you might be having problems because micflash can't find the Maintenance Mode Handler - which needs to bring the coprocessor up to a safe known state with minimal services. Hence the boot failure status you are seeing.

removed

hi what type of software or application you are trying to make my dear because you are asking about the boot and flashing both

 

Thanks for the comment, Frances. Indeed, I didn't have all the MPSS components installed. I've ended up downloading MPSS for Suse rpm files, then aliened them to deb, installed, and then compiled mic.ko from the sources. The micflash update went smoothly.

I may post my procedure of MPSS 3.1.2 installation on ubuntu 12.04 since there is some interest in it on the forums.

Alexei, happy to hear you were able to get moving.   Yes, if you want to share your procedure for Ubuntu, I am sure others will appreciate it!

Belinda Liviero

Thanks, Belinda.  Below are the notes with MPSS 3.1.2 installation on Ubuntu 12.04 in case someone is interested.

1. Download "SuSE SLES11 SP3" of mpss-3.1.2 from
   http://software.intel.com/en-us/articles/intel-manycore-platform-softwar...

    tar -xvf mpss-3.1.2-suse-11.3.tar

2. Convert the rpm to deb packages with alien and install:
    cd mpss-3.1.2
    alien --scripts *.rpm
    dpkg -i *.deb

3. Add directory /usr/lib64, containing the MPSS shared libraries, to the dynamic linker:

    echo '/usr/lib64' > /etc/ld.so.conf.d/mic.conf
    ldconfig

4. Download SOURCE of mpss-3.1.2 from
   http://software.intel.com/en-us/articles/intel-manycore-platform-softwar...

   tar -xvf mpss-src-3.1.2.tar
   cd mpss-3.1.2/src/
   tar -jxvf mpss-modules-3.1.2.tar.bz2
   cd mpss-modules-3.1.2

5. Download patch mpss_mod_patch.txt from the attachment below into the module source root directory and apply it:

   patch -p1 < mpss_mod_patch.txt

6. Compile and install the kernel module, mic.ko:
   Download install.sh script from
   https://github.com/xdsopl/mpss-modules/blob/master/install.sh, make it executable and run:

   chmod 755 install.sh
   ./install.sh

7.  Try to load the MIC module:
    depmod
    modprobe mic

    you should be able to see mic devices:
     ls /dev/mic*

8. Create initial default configuration for the mic cards:
    micctrl --initdefaults

9.  Get the the mpssd startup script modified for ubuntu, mpss_ubuntu.txt, from the attachment below and copy it into /etc/init.d directory. 

     cp mpss_ubuntu.txt  /etc/init.d/mpss.ubuntu;   chmod 755 /etc/init.d/mpss.ubuntu

Start mpssd:
      /etc/init.d/mpss.ubuntu start

10.  Run command mpssinfo or micinfo.
    Note, "MPSS Version : NotAvailable" is normal for Ubuntu because one of the source files, host.c, contains call to rpm command:
    char *cmd = "rpm -qi mpss-daemon | grep Version";
   The command above won't work on Ubuntu.

 

 

 

 

 

 

 

Attachments: 

AttachmentSize
Downloadtext/plain mpss_mod_patch.txt2.41 KB
Downloadtext/plain mpss_ubuntu.txt4.24 KB

Hey Alexei K.,

Can you please reupload the files, because I need them and they are no longer available here.

Thanks in advance

Michael

I'm contacting our providers and will fix the link to the files.

Regards
--
Taylor

Hello!

I was trying to install MPSS-3.3.3 on Ubuntu 12.04 using the instriction suggested by Alexei K.

But the step 5 and 6 does not work... Could anyone help regarding that?

Thank you

Leave a Comment

Please sign in to add a comment. Not a member? Join today