Xeon Phi refuses Putty log in

Xeon Phi refuses Putty log in

Hi, I am trying to log into a Xeon Phi 3120A for the first time using Putty, but the log-in is refused and the connection asks for a password. What I am doing is: 1. Create public and private keys in puttygen (SSH2-RSA 1024 bit) 2. Register the public keys with the Xeon Phi with micctrl --addssh root -f "C:\Program Files\Intel\MPSS\bin\authorized_keys" It says: root: Updated with authorized key 3. micctrl --stop and then --start 4. Start putty and log into root@192.168.1.100 with SSH auth set to use the private keys saved in a ppk file. There is then a PuTTY Security Alert saying that the new rsa2 fingerprint does not match the one PuTTY has cached in the registry. If I click Yes to update the cache, the log in says: Using username "root" Server refused our key root@192.168.1.100's password:[] Any idea what I am doing wrong or what I should try next? Thanks

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Roger,

What MPSS version are you using? Also, could you include the output from "micinfo" command?

When creating the private key, make sure that the file called "authorized_keys"  doesn't contain .txt extension (e.g., "authorized_keys" and not "authorized_keys.txt".

Thank you.

Thanks for the reply.

MPSS version is 3.1.1.

There is no extension on the authorized_keys file name,

micinfo output gives:

System Info HOST OS : Windows OS Version : Microsoft Windows 8 Enterprise Driver Version : 3.1.1.0 MPSS Version : 3.1.1.0 Host Physical Memory : 65484 MB Device No: 0, Device Name: mic0 Version Flash Version : 2.1.02.0390 SMC Firmware Version : 1.16.5078 SMC Boot Loader Version : 1.8.4326 uOS Version : 2.6.38.8+mpss3.1.1 Device Serial Number : ADKC32800406 Board Vendor ID : 0x8086 Device ID : 0x225d Subsystem ID : 0x3608 Coprocessor Stepping ID : 2 PCIe Width : x16 PCIe Speed : 5 GT/s PCIe Max payload size : 256 bytes PCIe Max read req size : 512 bytes Coprocessor Model : 0x01 Coprocessor Model Ext : 0x00 Coprocessor Type : 0x00 Coprocessor Family : 0x0b Coprocessor Family Ext : 0x00 Coprocessor Stepping : C0 Board SKU : C0 QS-3120 P/A ECC Mode : Enabled SMC HW Revision : Product 300W Active CS Cores Total No of Active Cores : 57 Voltage : 997000 uV Frequency : 1100000 kHz Thermal Fan Speed Control : On Fan RPM : 2400 Fan PWM : 50 Die Temp : 51 C GDDR GDDR Vendor : Elpida GDDR Version : 0x1 GDDR Density : 2048 Mb GDDR Size : 5952 MB GDDR Technology : GDDR5 GDDR Speed : 5.000000 GT/s GDDR Frequency : 2500000 kHz GDDR Voltage : 1501000 uV

PS how is this formatting supposed to work?

If I enable rich-text my message gets rejected as spam.

If I disable it, it crunches everything together.

Hi Roger,

The output from micinfo on your system looks fine.

I just re-created public and private keys, and followed the information published in https://software.intel.com/sites/default/files/article/335818/intel-xeon-phi-coprocessor-quick-start-developers-guide-windows-v1-2.pdf (page 15 "Working directly with the uOS Environment Intel Xeon Phi Coprocessor"), I was successfully login the coprocessor using PuTTY.

I notice that you are using an older version of MPSS. Would you like to try the current MPSS 3.1.2 please?

Regarding your question on formatting, you can: 1. Attach your screen shot (click on "Select media"); 2. Edit your content on Notepad editor, then copy and paste; 3. Use other methods.

Installed 3.1.2 and went through the installation procedure etc.

Same result: "Using username "root" Server refused our key".

Can it be that when it says "root updated with authorized key" after the micctrl --addssh step, that it is lying and has kept an old key from an earlier attempt?

If that is possible, what would wipe that old key?

It has started working, but I would be more comfortable if someone could explain why, as if it stops again I will be back to square one.

As part of the installation process (page 9 of the Developer's Quick Start Guide 1.2), it said to give the command:
bcdedit -set TESTSIGNING ON

There was no corresponding OFF command in the guide.

I tried (amongst several million other things):
bcdedit -set TESTSIGNING OFF
and now it logs in.

I am not sure that this was what did it as I have been trying anything to get this have more computational power than a brick.
Is it plausible that this is the cause?
What does it do to the Xeon Phi logging?

I take a look on the readme-windows.pdf (Section 2.2.1) shipped with MPSS 3.1.2, it says:

user_prompt> bcdedit /deletevalue loadoptions
user_prompt> bcdedit -set TESTSIGNNING OFF

then restart the computer. Let me investigate this and get back to you soon. Thank you.

 

Hi, I am having this same problem. I cannot login to the PHI with putty.
I am using this guide:

C:\Program Files\Intel\MPSS\bin>micsmc -a

mic0 (info):
   Device Series: ........... Intel(R) Xeon Phi(TM) coprocessor x100 family
   Device ID: ............... 0x225c
   Number of Cores: ......... 61
   OS Version: .............. 2.6.38.8+mpss3.4.2
   Flash Version: ........... 2.1.02.0390
   Driver Version: .......... 3.4.34161.2
   Stepping: ................ 0x2
   Substepping: ............. 0x0

C:\Users\Administrator>ipconfig/all
   Description . . . . . . . . . . . : Intel(R) Xeon Phi(TM) coprocessor Virtual Ethernet Adapter (x64)
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.99(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0

C:\Program Files\Intel\MPSS\bin>bcdedit -set TESTSIGNING OFF
The operation completed successfully.

C:\Program Files\Intel\MPSS\bin>puttygen

C:\Program Files\Intel\MPSS\bin>micctrl --addssh root -f "C:\Program Files\Intel\MPSS\bin\authorized_keys"
root: Updated with authorized key

C:\Program Files\Intel\MPSS\bin>micctrl --stop
The Intel(R) Xeon Phi(TM) coprocessor is stopping.
mic0: ready

C:\Program Files\Intel\MPSS\bin>micctrl --start
The Intel(R) Xeon Phi(TM) Coprocessor is starting.
mic0: online (mode: linux image: C:\Program Files\Intel\MPSS\filesystem\bzImage-knightscorner.bin)

*** start putty -> connection -> ssh -> auth -> "private key file" (id_rsa_1024.ppk) [generated via puttygen.exe]

 

Intel_Xeon_Phi_Coprocessor_Quick_Start_Developers_Guide_Windows_v1_4_dot_PDF

Hi Tad,

When you launch the PuTTY* tool, under Category Session, you need to set the box "Host Name (or IP address)" to root@192.168.1.100  in order to login the coprocessor. Thank you. 

Loc,

exactly right, I was selecting the wrong address.  It works when selecting 192.168.1.100.  The 192.168.1.99 address shown with ipconfig.exe is misleading.

Thanks!

In static pair configuration, a private network is created for each pair of the host and each coprocessor. Each end of the private network is assigned an IP address.

In your case, there is a private network between the host and the coprocessor. The host's IP address is 192.168.1.99 and the coprocessor's IP address is 192.168.1.100 .  

Leave a Comment

Please sign in to add a comment. Not a member? Join today