MIC cannot open source file stdio.h

MIC cannot open source file stdio.h

hello i downloaded the Intel Parallel Studio XE 2013 and was running the LEO_tutorial on Visual Studio 2012.

After compiling the code i get the above error "MIC cannot open source file stdio.h" and

 Error    3    error #10340: problem encountered when performing target compilation    

I have both visual studio2010 and 2012 installed in my laptop (i wondered if this is the cause of problem)

any suggestions please




6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

this problem is similar to what was described in this thread:  , http://software.intel.com/comment/1773474#comment-1773474

You will want to make sure binutils is installed..... 

it appears that your question was posted multiple times to this forum, so be aware that we'll go in and delete the duplicates


Belinda Liviero


how do i install binutils, i do not see a folder called MPSS in c:\Program Files\Intel\MPSS

i tried deleting my duplicate post but it says "content not found", sorry about that


is it safe to assume you are trying to compile / learn on a system outfitted with an Intel(R) Xeon Phi(tm) coprocessor?   If yes, It sounds like you may not have the drivers installed for it, which we call the "Intel Manycore Platform Software Stack" -- available here:


(you will want to install the software for Windows....and follow the instructions, also available with the download, that explain how to install binutils)


Belinda Liviero

my machine does not have a  Intel(R) Xeon Phi(tm) coprocessor outfitted to it, 

thanks BELINDA L. after installing the drivers the program worked :)

Leave a Comment

Please sign in to add a comment. Not a member? Join today