micflash keeps hanging

micflash keeps hanging


I've been struggling with MPSS installation for some time now.

I started out in Ubuntu cross-compiling, but then gave up for obvious reasons. (didn't seem worth the trouble)

I installed CentOS 6.4 minimally, and started building necessary stack from ground-up, finally installing MPSS 3.1.4.

After I finished I mistakenly issued command for C0 stepping (micflash without -smcbootloader option)

I knew it was a mistake because /sys/class/mic/mic0/stepping has 'B1' in it.

It obviously failed, and I found a similar case on Developer Zone 

I tried the procedure offered there. (power-cycle, put mic in ready state, micflash with -smcbootloader)

Even though I tried multiple times, (I even updated BIOS version because it was the issue in some cases I found here)

I couldn't get it to work.

4G decoding and spread spectrum in the BIOS is enabled and disabled, respectively.

Whenever I use micflash command with -v (and sometimes it finds the valid images),

The images go from 9%, 19%, 28%, and then it keeps writing 0% until it times out.

What should I do now?

(I attached the tarball produced by micdebug.sh)

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Okay, this is my progress since I posted this.

I didn't realize that while I was 'yum update'ing from the minimal CentOS 6.4,

I unintentionally updated it to 6.5, which called for a kernel version that fit 6.5.

I took care of that.

Now micflash finds valid images every time I power cycle, but still, it times out.

I gave it a -v option to see its progress. Here goes:

No image path specified - Searching: /usr/share/mpss/flash
mic0: Flash image: /usr/share/mpss/flash/EXT_HP2_B1_0390-02.rom.smc
mic0: SMC boot-loader image: /usr/share/mpss/flash/EXT_HP2_SMC_Bootloader_1_8_4326.css_ab
mic0: Updating SMC boot-loader: 5%
mic0: Updating SMC boot-loader: 15%
mic0: Updating SMC boot-loader: 25%
mic0: Updating SMC boot-loader: 35%
mic0: Updating SMC boot-loader: 45%
mic0: Updating SMC boot-loader: 54%
mic0: Updating SMC boot-loader: 64%
mic0: Updating SMC boot-loader: 73%
mic0: Updating SMC boot-loader: 83%
mic0: Updating SMC boot-loader: 92%
mic0: Updating SMC boot-loader: 100%
mic0: Transitioning to ready state: POST code: 3d 
mic0: Transitioning to ready state: POST code: 3E 
mic0: Transitioning to ready state: POST code: 12 
mic0: Updating SMC: 1%
mic0: Updating SMC: 10%
mic0: Updating SMC: 20%
mic0: Updating SMC: 29%
mic0: Updating SMC: 39%
mic0: Updating SMC: 48%
mic0: Updating SMC: 58%
mic0: Updating SMC: 67%
mic0: Updating SMC: 77%
mic0: Updating SMC: 86%
mic0: Updating SMC: 0%
mic0: Updating SMC: 0%
... and it goes on like this.

This is actually after my first power cycle. First time I tried micflash it went on to update SMC boot-loader, Flash, and hung while updating SMC.

I will keep on going at it until I get some feedback,

but meanwhile, I'm attaching a copy of the new debug log, reflecting the changes I made so far.



Downloadapplication/x-gtar micdebug_20140306_162047utc.tgz504.24 KB

I finally got it to boot!

micflash worked after the second power cycle.

Its booting timed out after third, but it didn't after fourth!

Here's the micinfo after my first boot (just for my satisfaction):


Device No: 0, Device Name: mic0

        Flash Version          :
        SMC Firmware Version     : 1.16.5078
        SMC Boot Loader Version     : 1.8.4326
        uOS Version          :
        Device Serial Number      : ADKC24901626

        Vendor ID          : 0x8086
        Device ID          : 0x2250
        Subsystem ID          : 0x2500
        Coprocessor Stepping ID     : 3
        PCIe Width          : x16
        PCIe Speed          : 5 GT/s
        PCIe Max payload size     : 256 bytes
        PCIe Max read req size     : 512 bytes
        Coprocessor Model     : 0x01
        Coprocessor Model Ext     : 0x00
        Coprocessor Type     : 0x00
        Coprocessor Family     : 0x0b
        Coprocessor Family Ext     : 0x00
        Coprocessor Stepping      : B1
        Board SKU          : B1PRQ-5110P/5120D
        ECC Mode          : Enabled
        SMC HW Revision      : Product 225W Passive CS

        Total No of Active Cores : 60
        Voltage          : 939000 uV
        Frequency         : 1052631 kHz

        Fan Speed Control      : N/A
        Fan RPM          : N/A
        Fan PWM          : N/A
        Die Temp         : 99 C

        GDDR Vendor         : Elpida
        GDDR Version         : 0x1
        GDDR Density         : 2048 Mb
        GDDR Size         : 7936 MB
        GDDR Technology         : GDDR5 
        GDDR Speed         : 5.000000 GT/s 
        GDDR Frequency         : 2500000 kHz
        GDDR Voltage         : 1501000 uV

Thank Jun for sharing your experience. 

Leave a Comment

Please sign in to add a comment. Not a member? Join today