"sudo service mpss unload" FAILS

"sudo service mpss unload" FAILS

I am trying to upgrade my coprocessor from the preinstalled version 2.1 to the newest MPSS 3.2, but am having some issues. I am going through the readme here (http://registrationcenter.intel.com/irc_nas/4245/readme.txt) and am running into an issue with the steps to uninstall pre-3.x builds. The output of "sudo rpm -qa | grep -e intel-mic -e mpss" is


And when I try "sudo service mpss unload" I get

Shutting down MPSS Stack:
Removing MIC Module: FATAL: Module mic is in use.

I've tried all the suggestions by Frances Roth here https://software.intel.com/en-us/forums/topic/488872, but to no avail. The output of "sudo /opt/intel/mic/bin/micinfo" is

MicInfo Utility Log

Created Wed Jun 25 13:35:23 2014

    System Info
        HOST OS            : Linux
        OS Version        : 2.6.32-431.20.3.el6.x86_64
        Driver Version        : 6720-12
        MPSS Version        : 2.1.6720-12
        Host Physical Memory    : 65849 MB

Device No: 0, Device Name: mic0

        Flash Version          : NotAvailable
        SMC Firmware Version     : NotAvailable
        SMC Boot Loader Version     : NotAvailable
        uOS Version          : NotAvailable
        Device Serial Number      : NotAvailable

        Vendor ID          : 0x8086
        Device ID          : 0x225d
        Subsystem ID          : 0x3608
        Coprocessor Stepping ID     : 2
        PCIe Width          : x16
        PCIe Speed          : 5 GT/s
        PCIe Max payload size     : 256 bytes
        PCIe Max read req size     : 512 bytes
        Coprocessor Model     : 0x01
        Coprocessor Model Ext     : 0x00
        Coprocessor Type     : 0x00
        Coprocessor Family     : 0x0b
        Coprocessor Family Ext     : 0x00
        Coprocessor Stepping      : C0
        Board SKU          : NotAvailable
        ECC Mode          : NotAvailable
        SMC HW Revision      : NotAvailable

        Total No of Active Cores : NotAvailable
        Voltage          : NotAvailable
        Frequency          : NotAvailable

        Fan Speed Control      : NotAvailable
        Fan RPM          : NotAvailable
        Fan PWM          : NotAvailable
        Die Temp         : NotAvailable

        GDDR Vendor         : NotAvailable
        GDDR Version         : NotAvailable
        GDDR Density         : NotAvailable
        GDDR Size         : NotAvailable
        GDDR Technology         : NotAvailable
        GDDR Speed         : NotAvailable
        GDDR Frequency         : NotAvailable
        GDDR Voltage         : NotAvailable

Could I bet that I can just go ahead and upgrade to 3.2 without uninstalling the current MPSS 2.1? Any help would be much appreciated!


9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Try service mpss stop then unload. Update will be inconsistent without unload.

Best Reply

I see you have ofed installed. Try shutting down all the ofed services:

user_prompt> sudo service mpxyd stop
user_prompt> sudo service opensmd stop
user_prompt> sudo service ofed-mic stop
user_prompt> sudo service openibd stop 

If any of these services are running, the mic kernel module will believe it is in use.

Don't know which one did it, but that worked, Frances! Thanks!


[mjswartz@pn1249269 ~]$ service mpss status
mpss is stopped
[mjswartz@pn1249269 ~]$ service mpss unload
Shutting down MPSS Stack: 
Removing MIC Module: FATAL: Module mic is in use.
[mjswartz@pn1249269 ~]$ sudo service mpxyd stop
[sudo] password for mjswartz: 
[mjswartz@pn1249269 ~]$ su
[root@pn1249269 mjswartz]# sudo service mpxyd stop
Stopping mpxyd daemon:                                     [  OK  ]
[root@pn1249269 mjswartz]# sudo service opensmd stop
opensmd: unrecognized service
[root@pn1249269 mjswartz]# sudo service ofed-mic stop
Stopping OFED Stack:
mic0                                                       [FAILED]
hostFATAL: Module ibscif not found.
[root@pn1249269 mjswartz]# sudo service openibd stop
Unloading HCA driver:                                      [  OK  ]
[root@pn1249269 mjswartz]# service mpss unload
Shutting down MPSS Stack: 
Removing MIC Module:                                       [  OK  ]


Now a new problem! I'm on step 5 of the installation readme, attempting the command "sudo modprobe mic", but get the following error:

FATAL: Could not open '/lib/modules/2.6.32-431.20.3.el6.x86_64/weak-updates/mic.ko': No such file or directory

Any ideas where mic.ko is?


For your info, in my system, it is the service mpxyd that uses mpss service. Stopping  mpxyd will allow me to unload mpss.

Can you try

% find / -name mic.ko -print

Again, in my system, it shows


Found mic.ko in a similar folder. Copies mic.ko over and installation was successful. Thank you guys for the help!

I also had these two problems when upgrading from MPSS 3.x to 3.2.3. I found that the easiest way to avoid them is to reboot the host after uninstalling the old MPSS (and OFED packages on top of it). Perhaps instructions in readme.txt should call for a reboot?

Leave a Comment

Please sign in to add a comment. Not a member? Join today