MPSS 3.3.1 MLNX OFED 2.1.x problems on RHEl 6.4

MPSS 3.3.1 MLNX OFED 2.1.x problems on RHEl 6.4

Upgraded RHEL 6.4 host with 2 5110P to MPSS 3.3.1 (latest)

Trying to install MLNX OFED 2.1.x support as described in paragraph 2.1 of MPSS-Users_Guide.

No issues with compiling new set of drivers from source, but failed depndencies when i try to install them:

 rpm -U ofed-driver-2.6.32-358.el6.x86_64-3.3-1.x86_64.rpm
        file /etc/udev/rules.d/90-ib.rules from install of ofed-driver-2.6.32-358.el6.x86_64-3.3-1.x86_64 conflicts with file from package mlnx-ofa_kernel-2.1-OFED.2.1.1.0.6.1.g75b4801.rhel6u4.x86_64

 

 rpm -U dapl-2.0.42.2-1.el6.x86_64.rpm
error: Failed dependencies:
        dapl = 2.0.40mlnx1-OFED.2.2.24.gd52df45 is needed by (installed) dapl-utils-2.0.40mlnx1-OFED.2.2.24.gd52df45.x86_64

 

Am i supposed to install MLNX OFED without kernel and dapl support ? (there is no mention of this in users guide).

 

regards,

Marek

 

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The particular dependency problems are different from those in 520271 but I suspect that there might be a more general issue here. In any event, I have added your problem to my request for help on 520271. 

What is particularly strange is Loc installed the Mellanox OFED 2.1 on one of the machines in our team's lab and had no problems. So what is different about our machine? I'm not seeing it but there is obviously something. Let's see what the experts have to say. 

The word I have is - use the gcc compiler rather than icc for building all OFED related files.Is that what you did?

Thank's for quick response.

Indeed, icc is default compiler at this site. I will try with gnu and come back with results.

Anyway - after manual install of all the files from build rpm's all seems to work OK, both on host and on mic's.

regards,

marek

Hi Frances,

I saw in some release notes that Mellanox OFED 2.2 is supported?  I have that installed and the installation goes ok without errors, but there isn't an ofed-mic service installed after I follow the steps in the User's Guide.  Is that to be expected?

Thanks,

Todd

Intel Corporation
Technical Computing Group
Intel® MIC System Software Applications Engineering
Senior Platform Application Engineer

Hi,

I have installed Mellanox OFED with MPSS-3.3. I am getting error in ibv_devinfo

Failed to query device propshca_id:    mlx4_0
    

Can anybody help on the same?

AKS

I am getting that error with Mellanox OFED-2.2. I forgot to mention in last comment

Ashish,

Your post seems to have been lost. Is this still an issue?

Regards
--
Taylor

Leave a Comment

Please sign in to add a comment. Not a member? Join today