Phi x200 not found? Help?

Phi x200 not found? Help?

I'm trying to get up and running with a Phi 7220p Coprocessor card.  I'm running on Windows 10, installed mpss 3.8, but I do not see the coprocessor in Device manager.  miccheck reports that driver hasn't been loaded, and I see two yellow triangles in device manager for 'base system device' and 'coprocessor', both of which say they need drivers.

I've seen other users report using mpss 4, but I don't seem to have access to this on the Intel site.  Is there something I'm missing?

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Check your system BIOS to verify (and set) a parameter that permits PCIe devices to be located above 4GB (as well as having an aperture larger than 4GB). The wording for this option varies amongst motherboard and BIOS vendors, some motherboards/BIOSs do not support this feature. FWIW I have an ASUS P9X79 WS motherboard, this option is not documented in the User Guide, but is available when paging through the menu settings. This board is about 6 years old, an newer motherboards may document this feature better.

Jim Dempsey

Yes, I have that option and I turned it on.  I tried this in a motherboard without that option and couldn't even POST (due to the PCI subsystem failing to allocate resources during boot).

More testing: I borrowed a x100 card (5110p) and set it up.  It works fine.  Procesor is an i5 4430S (Haswell).

Are you certain that the x200 cards can work with the (what I perceive to be) older MPSS drivers?

You will need the mpss 4.x stack in order to get your Xeon Phi x200 card working. Contact Intel (or someone from Intel reading this forum: please respond!)   to get access to the mpss 4.x driver stack.


@JJK, thanks for confirming my suspicions.  I 'chatted' with a person from Intel, who said that 'they couldn't get in touch with a tech', but they'd 'continue the discussion over email'...  I've yet to hear anything from them today...  I tried to make it clear that I'd like the MPSS 4 drivers, before going through the rigamarole of 'hardware debugging' (turn it off, re-seat it, turn it on, 'did that work?').

Forget Intel.  They are of no help.  I contacted support a while ago and the technicians gave me the standard spiel that it is unsupported and hence you are on your own.  Send me a PM and I'll tell you where you can grab MPSS 4.x...


...Perhaps I'm missing something, how do I send you a PM?

You can email me at quant.geek on gmail



Leave a Comment

Please sign in to add a comment. Not a member? Join today