Xeon Phi offload openmp segmentation fault

Xeon Phi offload openmp segmentation fault

Hello,

I'm executing some simple Xeon Phi OpenMP codes.

(From https://software.intel.com/en-us/xeon-phi/mic/training)

#include <stdio.h>

int main(int argc, char* argv[])
{
  const int count=10;
  int a[count], b[count];
  int c=5;
  int d=7;
  for (int i = 0; i<count; i++)
  {
    a[i]=0;
    b[i] = (i+1)*100;
  }

  #pragma offload target(mic) 
  #pragma omp parallel for
  for ( int i = 0; i < count; i++ )
  {
    a[ i ] = b[ i ] * c + d;
  }

  for (int i = 0; i<count; i++)
  {
    printf ("%d\n", a[i]);
  }
}

 

I tried to execute it, but my system just printed "segmentation fault". I wanted to debug it, so I tried to use gdb with core dump. But, I couldn't get any information.

Who could help me?

 

My system is

Host: i7-5820K, CentOS 7.6 (kernel: 3.10.0-957.el7.x86_64), MPSS 3.8.4, using icc in Parallel Studio XE 2016 Update4

Device: Xeon Phi 71S1P(miccinfo: B1PRQ-7110 P/X)

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

what happens if you try

icc -g -o offload-code -std=c99 -qopenmp offload-code.c
gdb-ia offload-code

and then type 'r' to run the code?

 

(the sample code works on my boxen)

Thanks to sharing these codes, but can you elaborate that what these codes are used for? Also, if you are willing to make your career in the IT department, earning CISCO certification, could help you out to gain better results.

The best CCIE Routing and Switching Lab Crams would be provided by many institutions, but for me, the best one would be the SPOTO CCIE Club, they have the best CCIE LAB Dumps, which are cheap as well as totally reliable.

My computer printed

[root@localhost slide12]# /opt/intel/bin/gdb-ia offload-code
GNU gdb (GDB) 7.8-16.0.881
Copyright (C) 2014 Free Software Foundation, Inc; (C) 2013-2016 Intel Corp.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For information about how to find Technical Support, Product Updates,           
User Forums, FAQs, tips and tricks, and other support information, please visit:
<http://www.intel.com/software/products/support/>.For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from offload-code...done.
(gdb) r
Starting program: /root/Download/beginningslides-extractedcode/02_Offload_Compilation/slide12/offload-code

Catchpoint -2 (signal SIGSEGV), 0x00007ffff6ac9e9e in ?? ()
(gdb)
 

At that time, 'miccheck' printed "Status: OK". And more simple code(non-openmp offload printf) worked.

 

If I re-install MPSS with CentOS 7.3, could I get a good result?

the same test program runs fine on my CentOS 7.6 (3.10.0-957.5.1.el7.x86_64) MPSS 3.8.4 box. You can find my binary at https://www.nikef.nl/~janjust/mpss/offload5

Can you try this binary and see whether it runs on your machine?

 

I tried to run it, but it also printed what I had seen. I'll try to reinstall this system.

Thank you so much :D

Leave a Comment

Please sign in to add a comment. Not a member? Join today