PBS queuing issues

PBS queuing issues

I am trying the simple hello_world example using a script like this (calledMTL_hello.sh):#!/bin/sh#PBS N myjob#PBS -j oeexport OMP_NUM_THREADS=16./hello_worldThen I submit and get no indication that the job ran, like this:[mcls-s15@acano01 ~]$ gcc -fopenmp -o hello_world hello_omp.c[mcls-s15@acano01 ~]$ qsub -l select=1:ncpus=16 /home/mcls/mcls-s15/MTL_hello.sh[mcls-s15@acano01 ~]$ qstat -aNothing is displayed at all from the qstat command and no output is written. Can you tell me whether there is something amiss with submitting jons?My student reports that this simple script also wasn't working:#!/bin/sh

#PBS -N testjob
#PBS-o out
#PBS -e err
#PBS -l select=1:ncpus=1:host=acano02


3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Have you tried using fully qualified pathnames in your script? I get jumpy when I see


instead of

/home/useraccount/bin/PBS # for example

Pleasegive that a try and report back if that works, or if the problem stays the same, or changes.



Tried running both scripts as is, the student script works fine.

The first script just goes nowhere. I suspect it has to do with the: #PBS N myjob. The '' appears to not be a valid '-'.

Note: If the script is accepted by PBS then you should get a job #.

Leave a Comment

Please sign in to add a comment. Not a member? Join today