Xcode 4.3

Xcode 4.3

Hi,I just updated to Xcode 4.3 and for installing intel fortran plus MKL I have to specify the Xcode folder. Now Xcode is entirely in Applications and not in developer folder anymore. I get an error message if I choose applications as the Xcode folder. Any solutions out there yet? Thanks a lot.

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,the same here. I tried all of/Applications/Xcode.app/Contents /MacOS (where the actual Xcode executable resides),/Applications/Xcode.app/Contents/Developer, etc. non was accepted by the intel composer XE installer. I installed command line support only for the time being, but would appreciate any suggestions.Thanks and regards.

Theproblem may be the Xcode version is not supported by the installer. I checkedIntel Composer XE release notes, saw
System Requirements
An Intel-based Apple* Mac* system
1GB RAM minimum, 2GB RAM recommended
3GB free disk space
One of the following combinations of Mac OS* X, Xcode* and the Xcode SDK:
o OS X 10.7 and Xcode* 4.2 and SDK 10.7
o OS X 10.7 and Xcode* 4.1 and SDK 10.7

Regards,
Ying

Hello

Sorry, we don't support Xcode 4.3 yet.

As a work-aroundI can suggest you toenter "/"as Xcode install directory. Installer must accept this. But I can't guarantee that the actual integration will besuccessful, sincewe haven't implemented support for Xcode 4.3 yet. You can try, but I am not sure it will work.

/ Natalia

Best Reply

Right-click installer -> Show contentsnavigate into:composer_xe_2011_sp1.9.289(Right-click -> Show contents)extract:Archive.pax.gzcopy/xcode_icc/4.2/Library/Xcode/Third-Party\ Plug-ins/ICC\ 12.1\ Compiler.xcplugininto/Applications/Xcode.app/Contents/Developer/Library/Xcode/Third-Party\ Plug-ins/ICC\ 12.1\ Compiler.xcpluginedit/Applications/Xcode.app/Contents/Developer/Library/Xcode/Third-Party\ Plug-ins/ICC\ 12.1\ Compiler.xcplugin/Contents/Resources/ICC\ 12.1.0.xcspecto replace$(DEVELOPER_USR_DIR)with/opt/intel/composerxeafter that, replace-dev-usr-root=/opt/intel/composerxewith-dev-usr-root=/Applications/Xcode.app/Contents/Developer/usrsave. restart XCode.works for me :)

Has anyone tried Hajo's solution? I'm looking for confirmations or the opposite.

If you take the following link at face value, it would appear that the above isn't going to help us:

http://software.intel.com/en-us/forums/showthread.php?t=103290

Following up on this, I've adapted Hajo's solution to my setup and now have Xcode 4.3 installed under OS X 10.7.3 and compiling with the Intel Fortran Compiler 12.1.2 (from Composer XE). Syntax coloring works, but is disappointingly primitive.

Incidentally, Steve Lionel's post "Do not install Xcode 4.3 if you are using Intel Compilers" seems to be rather damning to the effort. I'm not sure if I've missed something important but, like Hajo says: "works for me." As always: caveat emptor; YMMV; etc.

Here's a brief summary in hopes that it might save someone some time in their installation. (And I'm sure I'll have to do this again, so it's not as selfless as it sounds.)

I started with 10.7.2 and Xcode4.2 installed. Downloaded 'MacOSXUpdCombo10.7.3.dmg' to update to 10.7.3 (reminder to back-up your files, though I didn't); downloaded 'xcode_4.3_for_lion.dmg' (don't bother with the App Store, use: https://developer.apple.com/downloads/index.action).

Do the standard 'dmg install routine' (installs into /Applications -- I didn't want it there so I moved it to /Developer/Applications/Xcode4.3.app -- just mentioning this so you know that it works).

Now, you're in a position to start following Hajo's remarks. However, if you have Xcode4.2 installed already, you don't have to bother with the file "composer_xe_2011_sp1.9.289" that Hajo mentions (and I couldn't find anyway).

Your objective is copy the 'IFORT 12.1.0.xcspec' files from the Xcode4.2 distribution to the 4.3 dist. And to modify this file to let it know where the ifort compiler is and where some environment information is.

On my system the Xc4.2 'xcspec' file is in '/Developer/Library/Xcode/Third-Party\ Plug-ins/IFORT\ 12.1\ Compiler.xcplugin/Contents/Resources'

I copied the entire 'Third-Party Plug-ins' directory to: '/Developer/Applications/Xcode4.3.app/Contents/Developer/Library/Xcode' as:

cp -a /Developer/Library/Xcode/Third-Party\ Plug-ins /Developer/Applications/Xcode4.3.app/Contents/Developer/Library/Xcode

Now, follow Hajo's remarks on modifying 'IFORT 12.1.0.xcspec' to the letter.

Incidental remark: I think the 'ICC' directories in Hajo's post are there due to what I guess is his 'Intel Composer XE' distribution. I don't have that since I've got the 'Intel Fortran Composer XE'.

Hajo: sorry I ever doubted you, buddy. Thanks.

Leave a Comment

Please sign in to add a comment. Not a member? Join today