Pardiso - possible error in latest upgrade

Pardiso - possible error in latest upgrade

Hi,I am writing a finite element application using IVF and the PARDISO linear solver that comes with the MKL libraries. My application was working fine until 3rd January 2011 when I upgraded tow_mkl_10.3.1.127_ia32. Following the upgrade the solver failed at the numerical factorisation phase (PHASE=22). Instructions in the userguide tell you that to set the default parameters one should pass IPARM(1)=0 at the analysis phase (PHASE=11) however on inspection of IPARM following the analysis phase I found that some elements of IPARM had not been set to their default values, for example IPARM(28) which only admits values of 0 or 1 with 0 being the default remained unchanged at -1 which was the value present in the uninitialised array. In seeking a solution to this issue I replaced the initialisation IPARM(1)=0 with IPARM=0, i.e. setting all elements of IPARM to zero, prior to performing the analysis phase. This appeared to solve the problem.Inspection of the results produced by PARDISO seems to indicate that they are fine with this work-around but I am now left with some uncertainty as to whether or not IPARM is being correctly initialised to appropriate default values (it could be the case that by setting IPARM=0 allowed PARDISO to run for my particular problem configuration but some of the elements of IPARM are not now at sensible default values).Thanks,ACAR

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Do you mean that you had not seen this behavior with the previous version?say, for example, with the 10.2?

Yes that is what I observed - the code was working correctly until I installed the upgrade for mkl and for IVF. That is not to say, of course, that the vector IPARM did not enter phase 1 with different values as I did not initialise it explicitly since according to the documentation this is not required. Unfortunately now that I have installed the upgrades I cannot confirm the outcome of the initialisation for the older version of the libraries.

Almost a week since I asked a fairly important question and still no response (admittedly running over a holiday period)! Is anyone taking note of the question? Just rebooted my machine and tried to find the mkl forum via the website - it took me numerous attempts via the intel search engine to find anything to do with forum. This is a general problem that I have with the intel website - it is not easy to return to your previous settings. Now I have found my way in I shall record it for future use but really should there be an issue with shoving "forum" into the intel searh engine?Best wishes,Angus.

it looks likeabug.Wewill checkandbe back soon.--Gennady

Many thanks for the update - Angus.

Do we know whether this is a bug yet?

Best Reply

Hi Angus.This is the bug. The fix will available the next update. I will let you know as soon as this update will available.--Gennady

Hi Gennady,Thanks for the update. For my use of PARDISO it seems that what I've already done is okay. For users with other problem types they may need to ensure that the relevant parameters are correctly set by setting them manually. I look forward to hearing of the next update.Cheers,Angus.

Hi Angus,The problem has been fixed in the latest version of the Intel MKL 10.3. Update 2 released yesterday. This Update is available now on the Intel Registration Center.Could You please check if the problem is still there and let us know the status.--Gennady

Hi Gennady,Great. Happy to test it out but could you please supply a link as I haven't the time to wander blindly around the Intel Website.Thanks,Angus.

Hi Angus,Please see the officialannouncementhereand this is the link to theIntel Software Development Products Registration Center--Gennady

Hi Gennady, I've installed the update but can't do the required check at the moment. Will let you know the outcome when I do.

Leave a Comment

Please sign in to add a comment. Not a member? Join today