Library not loaded: libmkl_intel_ilp64.dylib

Library not loaded: libmkl_intel_ilp64.dylib

Hello everyone,
I'm new in mac and with IMKL too, trying to get up some f90 codes for signal processing in a

Macmini3,1. 1Proc, two cores (In the near future we expected to run our applications in a cluster of similar Macs).

After a while I was able to compile without errors, nevertheless the executable doesn't run. Showing the error in the thread title. Here down details:

MKLPATH=/Developer/opt/intel/Compiler/11.1/088/Frameworks/mkl/lib/em64tMKLINCLUDE=/Developer/opt/intel/Compiler/11.1/088/Frameworks/mkl/include/em64t/ilp64Script:ifort -o exec $1 $2 -L MKLPATH -I MKLINCLUDE/Developer/opt/intel/Compiler/11.1/088/Frameworks/mkl/lib/em64t/libmkl_intel_ilp64.dylib /Developer/opt/intel/Compiler/11.1/088/Frameworks/mkl/lib/em64t/libmkl_intel_thread.dylib /Developer/opt/intel/Compiler/11.1/088/Frameworks/mkl/lib/em64t/libmkl_core.dylib /Developer/opt/intel/Compiler/11.1/088/lib/libiomp5.dylib -openmp -lpthreadwhen you execute your recently compiled file, the following output is shown:dhcp-0083712665-16-41:FFT_INTEL_MAC erwin$ ./execdyld: Library not loaded: libmkl_intel_ilp64.dylibReferenced from: /Users/erwin/Desktop/FFT_INTEL_MAC/./execReason: image not foundTrace/BPT trapdhcp-0083712665-16-41:FFT_INTEL_MAC erwin$ ./execdyld: Library not loaded: libmkl_intel_ilp64.dylibReferenced from: /Users/erwin/Desktop/FFT_INTEL_MAC/./execReason: image not foundTrace/BPT trap___I'll thank any help or comment you can share with me.In advance thanks a lot.C. Evans

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,Have you setDYLD_LIBRARY_PATH to point to the directory location of the Intel MKL dylib's?Example:

export DYLD_LIBRARY_PATH=/Developer/opt/intel/Compiler/11.1/088/Frameworks/mkl/lib/em64t/


Hello Todd,

Thank you for your
answer, I already included this path and the compilation is
going well, but now when Im trying to run de application the following output
is obtained:


dyld: Library not
loaded: libiomp5.dylib

Referenced from:

Reason: image not

Trace/BPT trap

I looked for this
particular library to address the compilation to take into account it, and
there are

sh-3.2# find / -name libiomp5.dylib -print



find: /dev/fd/3: Not a directory

find: /dev/fd/4: Not a directory






I tried to compile pointing out to all of these paths,
nothing worked. So I copied the libiomp5.dylib file to the folder


and now I was able to compile with out errors.
Nevertheless there are some run time errors:

dhcp-0083712665-16-41:FFT_INTEL_MAC $ ./exec

forrtl: severe (174): SIGSEGV, segmentation fault

PC Routine
Line Source

libmkl_intel_ilp6 0000000100109196
Unknown Unknown

libmkl_intel_ilp6 0000000100108DB6
Unknown Unknown

Unknown Unknown Unknown

Unknown Unknown

Unknown Unknown

dhcp-0083712665-16-41:FFT_INTEL_MAC $

One of the probs could be that the libiomp5.dylib is
not loaded into the OS. Doing this with + ldconfig in linux is extremely
easy, but I dont know how to do this in Mac OS X.

Any advise will be very welcome!

Thank you for your attention.




In OSX* there are fat MKL libraries, so please set DYLD_LIBRARY_PATH to MKL lib location without arch-specific word just .../mkl/lib


-- Victor

Hi all sorry to bother you but I'm having similar problems.

I get this error when running first v 12

dyld: Library not loaded: libiomp5.dylib

So I tried fixing it by entering this into the console 


but no luck.

any hints would be much appreciated 


Leave a Comment

Please sign in to add a comment. Not a member? Join today