-ldfftw

-ldfftw

Hi everyone.
I'm installing the mpgrafic code in order to create large cosmological initial conditions.
I start with ./configure and the reply is
...
checking for Fortran libraries of mpif90... -L/usr/local/lib -lmpichf90 -lmpich -lpthread -lrt -L/opt/intel/fce/10.0.023/lib -L/usr/lib/gcc/x86_64-redhat-linux/4.1.2/ -L/usr/lib64 -lifport -lifcore -limf -lsvml -lm -lipgo -lirc -lirc_s -ldl
checking for fftw3d_f77_create_plan in -ldfftw... no
Error! You need to have (double precision) fftw library.

Somebody can help please.
Thank you.

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

Your configure script is looking for FFTW2 library and complaints it cannot find it to continue.There are several options to fix this.

You may download and install FFTW2.1.5 from fftw.org before running mpgrafic/configure - this shoul be easy.

You may use MKL's FFTW2 wrappers that can be found in interfaces/fftw2xf directory - this is a little bit trickier, because you should not only build the wrapper libraryandname it so that mpgrafic/configure could find it, but youalso should tell the configure to use MKL. Perhaps the easiest way to do the latter is to set environment variable LIBS before running configure:
export LIBS="-lmkl_intel_lp64 -lmkl_sequential -lmkl_core"

Thanks
Dima

Quoting - Dmitry Baksheev (Intel)

Hi,

Your configure script is looking for FFTW2 library and complaints it cannot find it to continue.There are several options to fix this.

You may download and install FFTW2.1.5 from fftw.org before running mpgrafic/configure - this shoul be easy.

You may use MKL's FFTW2 wrappers that can be found in interfaces/fftw2xf directory - this is a little bit trickier, because you should not only build the wrapper libraryandname it so that mpgrafic/configure could find it, but youalso should tell the configure to use MKL. Perhaps the easiest way to do the latter is to set environment variable LIBS before running configure:
export LIBS="-lmkl_intel_lp64 -lmkl_sequential -lmkl_core"

Thanks
Dima

joaquin,
some minor comment based on mkl linker adviser recomendation - please take into account to use -Wl,--start and -Wl,--end group symbols when linking application
--Gennady

Leave a Comment

Please sign in to add a comment. Not a member? Join today