A question about optimization solver

A question about optimization solver

I wrote a program with Optimization [Trust Region] solvers. But I found it can not run on the PC with Intel Pentium 4 Processors 520. What can I do to make it work? Is it related to the project properties?

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

It's not clear - what do you mean by "it can not run on the PC with Intel Pentium 4 Processors 520"?
What are the symptoms? What MKLversion you are using? What is your linking line?
--Gennady

The MKL version is V10.1.1. I use VC9 for coding. Released program closed itself without any promotion on Pentium 4 520. I included mkl_c_dll.lib mkl_solver.lib libguide40.lib into the linking lines.

Quoting - bingo_gmwu@yahoo.com.cn

The MKL version is V10.1.1. I use VC9 for coding. Released program closed itself without any promotion on Pentium 4 520. I included mkl_c_dll.lib mkl_solver.lib libguide40.lib into the linking lines.

What is your "environment"? VisualStudio (windows) or Eclipse (linux/unix). How you run the code? from command line, from within IDE?

what you mean by "promotion"? Is the code working in Debug mode?

A.

Quoting - bingo_gmwu@yahoo.com.cn

The MKL version is V10.1.1. I use VC9 for coding. Released program closed itself without any promotion on Pentium 4 520. I included mkl_c_dll.lib mkl_solver.lib libguide40.lib into the linking lines.

It seems that the problem with the improper linking like you are using: for example for win32,

Please try to use the following linking line for static linking:
mkl_solver.lib mkl_intel_c.lib mkl_intel_thread.lib mkl_core.lib libiomp5md.lib
or for dynamic:
mkl_solver.lib mkl_intel_c_dll.lib mkl_intel_thread_dll.lib mkl_core_dll.lib libiomp5md.lib

More info: how to link your application with Intel MKL, please see userguide
--Gennady

Quoting - ArturGuzik

What is your "environment"? VisualStudio (windows) or Eclipse (linux/unix). How you run the code? from command line, from within IDE?

what you mean by "promotion"? Is the code working in Debug mode?

A.

Thanks for your reply. Yes, my environment is VisualStudio. I run the program from the windows explorer. There is no IDE installed on the target computer.

Sorry, "promotion" means prompt, I wrote wrong words. I means there is no error message shown. The code works in release mode.

Quoting - Gennady Fedorov (Intel)

It seems that the problem with the improper linking like you are using: for example for win32,

Please try to use the following linking line for static linking:
mkl_solver.lib mkl_intel_c.lib mkl_intel_thread.lib mkl_core.lib libiomp5md.lib
or for dynamic:
mkl_solver.lib mkl_intel_c_dll.lib mkl_intel_thread_dll.lib mkl_core_dll.lib libiomp5md.lib

More info: how to link your application with Intel MKL, please see userguide
--Gennady

Thanks for your reply. I also thought I used improper linking lines. But it seemed not be easy to find out the right one from the userguide.

I tried your suggestion. But there is an error message:

OMP Error #15: initialize libiomp5md.dll. but found libguide40.dll already initialized.

Quoting - bingo_gmwu@yahoo.com.cn

Thanks for your reply. I also thought I used improper linking lines. But it seemed not be easy to find out the right one from the userguide.

I tried your suggestion. But there is an error message:

OMP Error #15: initialize libiomp5md.dll. but found libguide40.dll already initialized.

Check this KB article first.

A.

Leave a Comment

Please sign in to add a comment. Not a member? Join today