ZGGEV have problems compared with NAG library

ZGGEV have problems compared with NAG library

I am trying to use the lapack routine ZGGEV to comput the eigen value lamada of A*X=lamba*B*X with A and B complex*16 non-symmetric matrix. But the error info indicate The QZ iteration failed for some sets of A and B.

In my problem, I calculate 148 sets of different A and B for lamada. If I use the NAG subroutine F02GJF(), then all sets of A and B return correct eigen values. But if I tried the lapack routine ZGGEV (by Intel MKL), then only 36 sets return correct eigen value, and the others have error info which indicate failure in the QZ interation. I also tried the lapack routine ZGGEV provided by AMD's ACML library, then 72 sets of A and B return correct eigenvalue and the others also return the error info which indicate failure in the QZ interation.

I tried to adjust the work space size to optimal condiation, but no improvment for the perfomance.

Any suggestion to solve this problem?

Thank you very much!!

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Do you havea test data that can show this problem?

Yes, I have generated one set of test data. The input data files, source code and the output files are attached with this message.Thank you very much!

Thanks, phymilton. I am putting this question into our support website. So we will have one of support engineer to investigate this problem. Could you help to complete the steps bellow to get an account for https://premier.intel.com:

1. Access the page <http://www.intel.com/cd/software/products/asmo-na/eng/index.htm> to request one evaluation version serial number.

2. Register the serial number at the Registration Center web site.


Please choose Free Technical Support when you register the serial number on our registration center

3. You will receive an email within 24 hours with a license file attached. If you do not receive this email, contact us <<https://registrationcenter.intel.com/support>>.

Please let us know if you complete this. We will put this problem in support website.


Message Edited by ChaoY on 06-01-2006 08:22 PM

I tried to registrate and log in. But there are always an error as:
HTTP 404 - File not found

We're sorry, the page you requested can't be found on www.intel.com.So can you forward it to the premium forum.

Leave a Comment

Please sign in to add a comment. Not a member? Join today