Problems with the Pardiso Solver

Problems with the Pardiso Solver

I am recent to the MKL and am trying to build and test a simple Pardiso example that is listed in the distribution files. I am getting it to acess and run part way through the solver and then it dies with an error in the BLAS (see below). I have tried support and it has been 3 weeks with no response other than we are looking into it. I tried both the Compaq VF 6.6c and IVF 9 compilers and get the same issue. I even tried earlier IMK versions back to 7.x. This is their simple test case.

================ PARDISO: solving a symmetric indef. system ================

Summary PARDISO: ( reorder to reorder )
================
Times:
======
Time fulladj: 0.000134 s
Time reorder: 0.012670 s
Time symbfct: 0.000614 s
Time malloc : 0.001267 s
Time total : 0.019286 s total - sum: 0.004602 s
Statistics:
===========
< Parallel Direct Factorization with #processors: > 1
< Hybrid Solver PARDISO with CGS/CG Iteration >
< Linear system Ax = b>
#equations: 8
#non-zeros in A: 18
non-zeros in A (%): 28.125000
#right-hand sides: 1
< Factors L and U >
#columns for each panel: 80
#independent subgraphs: 0
< Preprocessing with state of the art partitioning metis>
#supernodes: 4
size of largest supernode: 4
number of nonzeros in L 31
number of nonzeros in U 1
number of nonzeros in L+U 32
Reordering completed ...
Number of nonzeros in factors = 32
Number of factorization MFLOPS = 0
MKL ERROR : Parameter 2 was incorrect on entry to DTRSM forrtl: severe (157): Pr
ogram Exception - access violation
Image PC Routine Line Source
TMK.exe 0045A1B6 Unknown Unknown Unknown

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

Just to let you know i have experienced exactly the same problem. Again still waiting ona response from intel premier support.

If you have worked around the problem in any way, please let me know.

Leave a Comment

Please sign in to add a comment. Not a member? Join today