MKL on a E3-1220 processors

MKL on a E3-1220 processors

Dear all,

I have been using the MKL library to compile and run the electronic structure code Wien2k for the last four or five years.

Everything was fine until the last month when I tried to installed the code in one of the computers that is based on the E3-1220 processor.
It gave me an error in the vdcos and vdsincos subroutines
(it compiled perfectly but the following message appeared:
severe (168): Program Exception - illegal instruction)

The code worked perfectly on our other computers in special in our cluster that uses the X3430 CPU.

I can run the code with the usual vcos and vsincos subroutines but of course it is not so efficient.

I compiled the code with the standard options given by the MKL line advisor:
$(MKLROOT)/lib/em64t/libmkl_solver_lp64_sequential.a -Wl,--start-group $(MKLROOT)/lib/em64t/libmkl_intel_lp64.a $(MKLROOT)/lib/em64t/libmkl_sequential.a $(MKLROOT)/lib/em64t/libmkl_core.a -Wl,--end-group -lpthread -lm -lguide

I have also tried with the last version of the ifort compiler and the MKL libraries but with the same, wrong, result.

Is there any option to add for this particular processor?

Any help will be very welcome!

Thanking you in advance,


4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

what version you use? it seems you use version 10.0. Please try to check the problem with one of the latest versions. you can download the eval version from intel registration center.

Dear Gennady,

Thanks a lot for your fast reply.
For most of my tests I have been using the MKL libraries that comes with the ifort compiler, 11.1.069. I think it is the 10.3 Update 9.
I have also tried the one that comes with one of the last suites, composerve-2011-5,
but obtained the same results.

Best and thanks again,


Ruben,-the version of MKL you are using is 10.2 Update 4 accordingly the KB article: can check it by yourself into mklsupport.txt file.- what OS you are working on?  i am asking because of with version 10.2.* ( all updates) we had run time issue describing into this article. - can you get one of the latest 10.3 updates from intel registration center and check the problem? You can get the evaluation version ( valid for 30 days).--Gennady

Leave a Comment

Please sign in to add a comment. Not a member? Join today