Option '-mkl' can't do static link in Intel Composer 2013update1

Option '-mkl' can't do static link in Intel Composer 2013update1

I found -mkl option can't do static link for MKL in Intel Composer 2013update1. But it works well in 2011_sp1_update3.

The folloiwing post in the Forum 'Intel® C++ Compiler ' contains the compling and linking commands for this issue.


Is this a bug for 2013? Will -mkl support static link later?


4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I don't see the problem on my side with Composer 2013 ( Package ID: l_ccompxe_2013.1.117 l_ccompxe_13.0.1.117 and w_ccompxe_p_13.0.1.119 )
I checked how it works on linux and windows 64 bit systems.

the compilation line:
icl /w /Fo /I"$(LINCL)" /Qmkl:parallel /Fedgemm.exe dgemm.cpp
icc dgemm.cpp -I${MKL_INCL} -mkl=sequential -o dgemm.out
it works for both systems.

Try putting the -mkl=sequential (or similar) option at the end of the command line (in particular, after any .o files).

If that works, then it seems like an options processing deficiency to me.

I am having the same problem. The exact code worked fine with 2011 update 3, but now MKL works only with a dynamic link. When I use a static link (which I require) I get lots of errors about the unavailability of BLAS and LAPACK.

I've tried both -mkl=parallel and -mkl=sequential and neither helps much.


Leave a Comment

Please sign in to add a comment. Not a member? Join today