mkl 10.2 - 64bit

mkl 10.2 - 64bit


I need to port an application to 64bit that uses the MKL library version 10.2 update 2. I am working with Visual Studio 2012 professional on a WIndows 7 machine.

I receive a LNK1136 error when linking to mkl_intel_lp64_dll.lib, which indicates that the archive is corrupt. To confirm, I ran dumpbin.exe on mkl_intel_lp64_dll.lib and receive a series of LNK4048 errors (invalid format file). Running dumpbin on and linking to the 32 bit libraries yield no errors.

I have tried repairing the installation and removing/reinstalling the libraries, but nothing changes.

Has anyone encountered this problem before or seen something similar? I should mention that I am currently using the evaluation version of MKL. Is the 64 bit functionality limited when using the evaluation version?

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


Please double check that namely 64-bit MKL libraries are used for linking: from em64t directory, not from ia32 were located 32-bit libraies.

Also, it would be helpful to get more details to analyze your problem and help. E.g. small reproducer and used project file....

-- Victor

Hi, have you considered updating to MKL 11.0.1? If not, is there a reason why you need to stick with that version? Please let us know so that we can help you better and get to the root cause of the problem. Thanks!

Leave a Comment

Please sign in to add a comment. Not a member? Join today