Dear developer:

I am writing to you in order to inform you about an unusual behavior that pardiso solver exhibit in the latest version of mkl library. More specifically, we use this solver in our finite element code in order to solve the linear system of equations. Up to version ..., we could solve systems that arise when periodic boundary conditions are imposed. Unfortunately, the latest version can not solve them and a NAN appears during back- substitution. We have used both intel and gnu compilers as well as multithreaded and sequential versions without any improvement. Finally, these can be solved with WATSON and HSL solvers.

I am looking forward for your response.

- Dimitrios Fraggedakis

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

the latest version - do you mean version 11.0 update1?

how we can check the problem on our side? can you give us the example? 

Here is the Matrix and instructions in the .zip file.

I am running the latest Intel Fortran Compiler Version.

I tried to run all my previous programs that did not crash before, and they crash now after the update. 


Downloadapplication/zip matrix-sizes.dat.zip934.1 KB

I modified the example pardiso_unsym_f.f from the MKL 11.0.1 distribution to read your data files, running under Windows 7 X64 using the compilers (32-bit and 64-bit). Your system was solved successfully and there were no NaNs in the solution vector.

Please provide code that reads your data files and produces the behavior that you described (NaNs in the solution).

Well, i foggot to mention thay my operating system is Linux Rocks 6.0 Mamba edition.

I am preparing the code to provide it to you as soon as possible.

Hi everyone... i have got the same problem calling PARDISO, while compiling using WIN7 64 there is no problem at all, compiling using linux Redhat works only while using a debug compilation, while compiling for release sends a NaN result during the back substitution and iterative refinement (phase = 33)... can any help me?

Linked libraries are: libmkl_intel_lp64.a, libmkl_intel_thread.a, libmkl_core.a

Debug command line:

  • ifort -g -traceback -check all -fp-stack-check -warn all -nogen-interface -assume bscc -heap-arrays -module debug -I/opt/intel/mkl/include   -static-intel debug/*.o -o bin/plcd-dbg_2014.03.x64.unix -Wl,--start-group "/opt/intel/mkl/lib/intel64/libmkl_intel_lp64.a" "/opt/intel/mkl/lib/intel64/libmkl_intel_thread.a" "/opt/intel/mkl/lib/intel64/libmkl_core.a" -Wl,--end-group -L"/opt/intel/mkl/../compiler/lib/intel64" -liomp5 -lpthread -lm


Release command line;

  • ifort  -O3 -no-prec-div -xHost   -no-vec -ipo -warn all -nogen-interface -assume bscc -heap-arrays -module release -I/opt/intel/mkl/include   -static-intel release/*.o -o bin/plcd_2014.03.x64.unix -Wl,--start-group "/opt/intel/mkl/lib/intel64/libmkl_intel_lp64.a" "/opt/intel/mkl/lib/intel64/libmkl_intel_thread.a" "/opt/intel/mkl/lib/intel64/libmkl_core.a" -Wl,--end-group -L"/opt/intel/mkl/../compiler/lib/intel64" -liomp5 -lpthread -lm

I am not sure if i made myself clear, since i have not experience on the matter. Thanks in advance.

regard to the previous issue - the problem has not been reproduced. The  system was solved successfully and there were no NaNs in the solution vector.

in your case - could you please give us the reproducer?   we don't see such problem with the latest version of mkl. what version do you use?


Oh God!, I am not sure yet, but i think is a huge mistake on my side :(... in any case, thank you very much for the quick answer... 


Leave a Comment

Please sign in to add a comment. Not a member? Join today