-mkl=parallel

-mkl=parallel

I am using the Intel Fortran Composer with the MKL library. I am calling pardiso to solve a sparse system of equations. Everything was working well in OS X using the -mkl=parallel option with the compiler update of  m_fcompxe_2013.1.119.dmg or previous versions. However, the results provided by pardiso are wrong now for newer updates. I incidentally changed the MKL option for -mkl=sequential and I was surprised to see that results were correct as before. So, my question is: what is going on? I should add that this problem is not happening with the Linux and Windows versions, where the -mkl=parallel option is working well for all compiler updates.

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

in that case we nned to have the example for reproducing the problem on our side -- this is an unknown issue with the latest version of mkl.

Leave a Comment

Please sign in to add a comment. Not a member? Join today