MKL 11.1 and scalapack / blacs_intelmpi

MKL 11.1 and scalapack / blacs_intelmpi

Hi,

I have just downloaded the new compiler package with ifort 14.0 but it seems to be missing the files

libmkl_blacs_intelmpi_lp64.so and libmkl_scalapack_lp64.so

as well as thier static counterpart and the 8-bit integer libraries. So I tried the mkl 11.1 evaluation version and it's missing these files too. Am I making a mistake during the installation or have the names changed and are now part of other libs?

Thanks, have a nice day, Jan

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Jan,

since MKL v.11.1 ( bundled with Composer v 14.0 ) by the default, sclalapck libraries are not installed.  You can choose the custom mode during installation and select Cluster Components of Intel MKL. Please let us know if any further issue.

--Gennady


Hi,

that worked, many thanks, Jan

Sorry to hijack the thread but I've installed 11.1 *with* the scalapack libraries included.

In the link line advisor for dynamic linking it suggests linking to mkl_blacs_msmpi_ilp64_dll.lib which doesn't seem to exist in my installation. Is my install incorrect, or is the link line advisor incorrect?

thanks David - we will check and will back soon.

David, this is the LA is incorrect. we will fix this issue. please try to link with mkl_blacs_ilp64_dll.lib in that case. thanks. 

Its been an year. Why dont you guys fix it?

Leave a Comment

Please sign in to add a comment. Not a member? Join today