cannot open mkl_intel_s.lib

cannot open mkl_intel_s.lib

Dear Intel support,

I have recently updated my installation (witch was Intel Fortran Composer XE 2011 SP1) with Parallel studio XE 2013 SP1.

One of the projects I am working on shows link error for Win32 platforms.

The build command says Fatal error LNK1104: cannot open file 'mkl_intel_s.lib'.

The same project builds fine for x64 platform and both were building properly with the former version of the compiler and MKL.

Looking in the installation directories, the mkl_intel_s.lib file is present in the MKL installed along with Intel Composer XE 2011 (directory C:\Program Files\Intel\Composer XE 2011 SP1.369\mkl\lib\ia32, MKL version 10.3 update 12) but the same directory for the version 11.1 of the MKL does not contains the library.

Furthermore, the version 10.3 update 12 contains 24 libraries but the 11.1 contains only 11.

The compiler switch for the use of the MKL library is /Qmkl:sequential.

Best regards,

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

In the latest version of Intel® MKL ( v.11.1 )  there is a new installation option which allows a user  to select the list of components he/she will need and install only these ones. Please refer to KB  Article describes this mode by following the link:

Dear Gennady,

Thanks for the information. I probably missed this possibility when installting. However, when I have installed the same product on a first computer I was able to select these options but not on the second one, the main difference is that on the first computer the Compaq Visual Fortran was already installed but not on the second one. Does this makes any difference ?

I have tried to modify the current installation on the second computer but I did not find any options to add. Everything seems to be already installed and furthermore, I did not find the "PGI* and Compaq* Visual Fortran compilers support for IA-32" option in the list either if I try to modify the Intel Parallel Studio XE 2013 SP1 installation or the Intel Composer XE2013 one.

Best regards,

Just in case: I suppose you would not have the option to install CVF support in MKL if you started out the installation by choosing 64-bit components, as you might well do on a machine where you don't have CVF.

The on-line installation starts out with an option to download only 64-bit components.  It is possible that one or more optional components fails to download, as if you hadn't requested it.  I haven't been able to make on-line Windows installation work, so I had to download the special package download manager and entire composer package, which then could be copied to each machine for installation.  Any time I tried the on-line installer, I had to remove the entire installation and start over.

Hi Tim,

Thanks for your reply, but I finally found that I missed the "Customize" button on the install screen. When I went back to modify the current installation, I was able to select everything needed and now it works correctly.

Best regards,


thanks Tim for letting us know.

Leave a Comment

Please sign in to add a comment. Not a member? Join today