warnings and remarks from MKL, what is the reason?

warnings and remarks from MKL, what is the reason?

Dear all,

I am testing the MUMPS Fortran 90 interface for some simple block right hand side solution however I get a buch of warnings and remarks. These are all related to spblas, lapack, rci interfaces.

What could be the reason of these warnings and remarks? Attached file is an example of the output of the make process. You can examine the compile flags and direct me as necessary.

Best regards,

Umut

AttachmentSize
Downloadapplication/octet-stream mkl_simple.log12.05 KB
3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Many of the Fortran include files (*.fi) supplied with MKL are not intended to be compiled with /warn:all and similar options. To silence the warnings related to the contents of the include files, while still receiving warnings related to your code, surround the INCLUDE statements in your code with the compiler directives shown below, for fixed-format source files:

cDIR$ NODECLARE
        INCLUDE "mkl_rci.fi"
cDIR$ DECLARE

In free format source files, change "cDIR" to "!DIR".

If you wish to speed up the compilation process, instead of using INCLUDE statements in your code, create modules that do the INCLUDE, and USE the modules in your source code.

Quote:

mecej4 wrote:

Many of the Fortran include files (*.fi) supplied with MKL are not intended to be compiled with /warn:all and similar options. To silence the warnings related to the contents of the include files, while still receiving warnings related to your code, surround the INCLUDE statements in your code with the compiler directives shown below, for fixed-format source files:

cDIR$ NODECLARE
        INCLUDE "mkl_rci.fi"
cDIR$ DECLARE

In free format source files, change "cDIR" to "!DIR".

If you wish to speed up the compilation process, instead of using INCLUDE statements in your code, create modules that do the INCLUDE, and USE the modules in your source code.

Hi,

Actually, I am only including mkl.fi and the includes in the log file are automatically included. However your suggestion did not help me. What I did as you have suggested is

!DIR$ NODECLARE
include 'mkl.fi'
!DIR$ DECLARE

for free source format.

Best regards,

Umut

Leave a Comment

Please sign in to add a comment. Not a member? Join today