MKL cluster solver: number of threads always equal 1

MKL cluster solver: number of threads always equal 1

Hello everyone,

I'm using the MKL cluster sparse solver but I found a problem related to the number of threads. In fact the number of threads for my example is kept equal to 1 for every calculation and is not maximize according to the maximum number or threads in my nodes.

Someone can help me?

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

what is the problem size? and how to you track the number of threads using by cluster solver? 

Hello,

My code is running on 2 or more MPI process. When I run my calculation the Cluster solver should maximize the number of threads per MPI process but is only using 1 threads per MPI process.

If I then build my exe file with Parallel library linking the library "mkl_blacs_intelmpi_lp64" the code works properly maximizing the number of threads but only in 1 MPI process. When I run the calculation with 2 MPI processes I got a segmentation error.

What can I do?

if segmentation fault happens, then please give us the example of this code and show how do you exactly linked launched this case.

You may also report the problem to Intel Online Service Center where you may share your code ( as well as data ) in a private manner.

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today