sample_decode.exe returns: error code -3

sample_decode.exe returns: error code -3

Hi,I am having trouble running the sample_decode.exe. It runs fine w/o the "-hw" switch; however, when I run the command with the switch I am gettingc:\\Program Files\\Intel\\Media SDK\\3.0.442.32245 Beta3\\bin\\x64\\sample_decode -hw h264 -i bbb.h264 -o bbb.yuvReturn on error: error code -3, .\\src\\pipeline_decode.cppReturn on error: error code 1, .\\src\\sample_decode.cpp 172The input file is demuxed h264 videoThanks!!!

Downloadapplication/octet-stream bbb.h26424.83 MB
Downloadimage/png cpuinfo.png28.75 KB
Downloadimage/png intel_driver.png23.31 KB
Downloadimage/png gpu.png17.89 KB
7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I solved the issue by loading the latestGraphics: Intel HD Graphics Driver for Windows version!

Glad to hear you resolved the issue.Regards,Petter

Hello,I get the same error on using the -hw option.My computer configuration isi7-2600K CPU @ 3.4Ghz, 8GB, 64-bit Windows 7, Service Pack 1The computer also has an installed graphics card GTX460 on PCI-Express bus.Can Intel Media SDK still leverage the GPU capabilities of the i7-2600K even though a discrete graphics card is installed.

Hi Manoj,

It seems your issue is due to the installed discrete gfx card. If the gfx card is set as the primary adapter the default Media SDK samples will not work with HW acceleration.

One way to resolve this is to make the Intel GPU the primary adapter (normally via BIOS). Alternatively you can initialize the Media SDK session with the MFX_HARDWARE... target as described in the Media SDK manual appendix.

More info can be found in this forum post:


Hi Petter,

I am getting this exact same issue only when using the -hw option.  I have the i7-3720QM CPU @ 2.6GHz.  I am running a MacBook Pro Mid-2012 with bootcamp installed and Windows 7 Ultimate x64.  I installed the lastest bootcamp drivers for my machine.  Any ideas?



I switched to a 13" MacBook Pro (without a discrete graphics card) and this issue resolved itself.

Leave a Comment

Please sign in to add a comment. Not a member? Join today