Problem with relative path to DLL in SDK.

Problem with relative path to DLL in SDK.

I have compiled the transcode sample from the Media SDK Beta 3.0, and I have tried to run it on three different processors, after having installed the SDK on each:i7 930 Bloomfield (OK)i7 720QM Clarksfield laptop (OK now)Quad Q6600 Kentsfield (OK now)When Init fails, the error code is (-3) MFX_ERR_UNSUPPORTED. I would have thought it would work on the Clarksfield, as CPU-Z shows the exact same processor capabilities as the Bloomfield (SSE up to and incl. 4.2), same Family and Ext Family.EDIT: I got it working on both other processors, by running from the bin\\win32 folder. Even though the SDK was installed, running from elsewhere fails. So it appears to look for the DLL relative to where it was compiled from, not an absolute path.EDIT2: From the list of 2nd gen Core processsors at, I see that none of the above qualify, so the Media SDK runs in software mode only on all of them :(

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Karl,Regarding your problem with not found dll, probably the reason is that you ran 64bit MediaSDK installer which adds bin\x64 to the system PATH variable and tried to run a 32bit application. In that case you should have added bin\win32 to the PATH manually. Or run from bin\win32 as you did.Regards,Nina

Thanks, I installed the 32-bit SDK on all systems. The problem was caused by a missing reboot/relogin on two of the systems. It appears updated system variables need a reboot to be seen from the cmd line, while user variable changes are seen after re-opening a cmd line.-Karl.

I see, I met such issue too, you are right about relogon. As I remember it also helps if you go to Computer->Properties->Advanced System Settings->Env Vars->System and just press OK.

Leave a Comment

Please sign in to add a comment. Not a member? Join today