Problem - Media SDK 2.0 sample

Problem - Media SDK 2.0 sample

It's my first thread.
I'mtest Intel Media SDK now.
When I run sample program to encode IYUV(4:2:0) 1920 x 1080p video to AVC, it works well. But encoded h264 file does not played in VLC.
(parameter : h264 -i d:\\sample_1080p.yuv -o d:\\encoded.mpg -w 1920 -h 1080 -f 30 -b 50000 -u speed -t 8 -dstw 1920 -dsth 1080)
Next, when I add parameter -hw to above parameters, some message shows error.

Return on error : .\\src\\pipeline_encode.cpp 638
Return on error : .\\src\\sample_encode.cpp 281

Test system : Intel Core i7-2600K CPU 3.40GHz, Mother board - Intel 6 Series/C200 Series Chipset Family. RAM 8G , OS - Microsoft Windows 7 Ultimate K, Graphic Adapter - Intel HD Graphics Family
onboard (Mother board vender/model - GIGABYTE/GA-H67A-UD3H-B3)

So I run Intel Graphics checker to check system graphic status I saw this messge

"A valid Interl integrated graphics device was either not detected and/or is not being utilized by the application. Please re-run this tool on a system conatining the Intel 4 Series Express Chipset or Intel HD Graphics."

Is there somebody to help me?

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


Intel Media SDK produces elementary streams (muxing into mp4 or mpeg container is outside the scope of the SDK). Elementary streams can normally not be played back by VLC or Windows Media Player.There are some vendors, such as Elecard, that provide tools for playing back elementary streams.

Regarding encoding using HW. Judging from the errors you see it looks like you having problems with your graphics driver. Could you please make sure you have the latest graphics driver installed?

Do you have a discreet graphics card installed on your system?


Thanks Petter.
It's authority problem of windows account.
I have tried to install Intel Media SDK by an account that incluedin "Administrators" group, then above problem occurs. (c:\Program Files\Common Files\Intel\Media SDK\s1\2.0\libmfxhw32-s1.dll file not installed)
But next time I try to install that SDK by "Administrator" account of system then that problem soloved.
:) thank.


Leave a Comment

Please sign in to add a comment. Not a member? Join today