Media SDK Mpeg 2 dshow filter sample decoder with not standard resolution

Media SDK Mpeg 2 dshow filter sample decoder with not standard resolution


I'm using sample mpeg2 directshow decoder filter from sdk
3.0 beta ( software decoding mode, never tried hardware mode) .

My problem happens with a video which has a resolution of

Video Render filter (VR, VR9, EVR) shows video frames with
an aspect similar to 4:3 but in fact should be similar to 16:9.

So after doing some debug at the decoder source code I found
in CDecVideoFilter::RenewSampleParams method that VIDEOINFOHEADER2 is received
with incorrect information, struct comes with dwPictAspectRatioX = 1 and
dwPictAspectRatioy = 1 (but should be dwPictAspectRatioX = 2 and
dwPictAspectRatioy = 1) and that produces the behavior explained above.

I need some help about what's happening, and detect where
the values are wrong filled (linked library,??) of course I can
override the values manually inside the method (which actually works ) but it's
a patch that I would not like to do unless there is no other option.

I tried with a similar video (604x304) but encoded with h264
and it displays correctly with VIDEOINFOHEADER2 filled ok (dwPictAspectRatioX = 2 and
dwPictAspectRatioy = 1) also others mpeg2 decoders ( like Microsoft DTV-DVD Video
Decoder ) works ok.

Thanks in advance


2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Double post. Please see the below thread for continued discussion

Leave a Comment

Please sign in to add a comment. Not a member? Join today