[GraphStudio/GraphStudioNext] DirectShow Filters - H.264 Decoder/Encoder Issue

[GraphStudio/GraphStudioNext] DirectShow Filters - H.264 Decoder/Encoder Issue

Hello everyone,

I have recently been tinkering with the Intel(R) Media SDK 2012 R3. In specific, I've been working with the DirectShow filters included with the Media SDK. (These are the pre-compiled ones registered to the system with the intaller)

My test system has the following specs:

Processor: Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz
Onboard GPU: Intel(R) HD Graphics 2000
RAM: 2.00 GB
OS: Windows 7 Professional 32-bit

The issue I'm having has to do with the decoder specifically. It is a little difficult to explain through text, so I will need to attach images to support what I'm trying to say. All graphs are being built with GraphStudioNext (the reason for this is that the file will not render automatically, this is due to how I have set this system up for testing).

As you can see in the screenshot below, I have set up a media file through the Intel(R) Media SDK (IMSDK) MP4 Splitter -> IMSDK H.264 Decoder -> Video Renderer (default Microsoft). The video plays as expected.


Now, if I use the same graph, add in an encoder, and then decode the encoded video, i.e. IMSDK MP4 Splitter -> IMSDK H.264 Decoder -> IMSDK H.264 Encoder -> Microsoft DTV-DVD Video Decoder -> Video Renderer (default Microsoft); We can now see that the decoded video is not played in the expected aspect ratio (this is not 4:3, this appears to be closer to a 1:1 ratio)


Encoder settings:


Lastly, if I strip off everything I added in the second configuration and revert to the first configuration, video playback continues to be in a bad aspect ratio. (Please note that I had to use the Enhanced Video Renderer here as I kept receiving a VFW_E_NO_ACCEPTABLE_TYPES error when trying to revert to the first configuration)


Is there any fix which I can implement into the filters to not have this issue occur? I will say again that I am NOT building these filters from source, they are the same filters that are registered with the IMSDK installer. I am, however, willing to build the filters from source with any fixes or code changes.

Please let me know if you have any suggestions!


7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I have tried the same configuration on Windows 7 Enterprise 64-bit. I still have the exact same issues, so it appears that 32/64 bit architecture does not matter for this problem.

I have also tried installing the Windows SDK for Windows 7 (v7.0) and DirectX 10 SDK (June 2010) to see if whether they are installed or not would make a difference, the answer is no. I am still having issues.

I have even tried a completely different system by taking the hard disk and booting it off of a different CPU (i7-2600), still the same issues.

Any suggestions would be greatly appreciated.


Hi there,

I am able to see the issue with aspect ratio you report. I will investigate why it happens and get back to you with a fix.

Regarding errors that you see when you change graph back and forth are likely caused by redundancy effects in filters, it's recommended to delete and re-create decoder filter each time you want to connect it to a different filter.


Hi Nina,

Thank you very much for your response! I'm glad to hear that it isn't an isolated issue. I look forward to hear your suggestions/fixes.


We have identified an issue in Intel Media SDK MP4 Splitter that we believe is causing wrong aspect ratio after transcoding on certain streams. Could you please share your stream so that we verify our fix? You can upload to ftp.intel.com\pub\incoming following the below instruction.


- ftp ftp.intel.com
- enter 'anonymous' as login
- for password enter your email address
- enter 'bin' to go to binary mode
-cd /pub/incoming
- Files are hidden (not visible), so please tell me the exact file name(s)
(Note:don't use underscores in file names)
- Files names are case sensitive
- Files will remain on ftp server for 24 hours and are
then deleted automatically
- Files greater than 100MB are not allowed by anonymous users

Hi Nina,

I have uploaded the file "SkyfallTrailer2.m4v" to ftp.intel.com/pub/incoming. It is 93.7 MB. I did not send the video I used for my testing as it is too large and I am unsure if it is copyrighted material or not. This file does, however, exhibit the same issue as described in my original post.

If it did not upload properly, please let me know.

I look forward to seeing the developed fix!


Best Reply


Thank you for sending the stream, it represents the same issue that we had root caused. The fix was made in Intel Media SDK MP4 Splitter filter (released in binary form, samples\_bin\\imc_mp4_spl_ds.dll) and will be available in Intel Media SDK 2013 which is expected to be published early 2013. Unfortunately, no immediate fix or workaround for the sample_dshow_plugins source code (video decoder and encoder filters) as the issue is essentially in how splitter filter calculates display aspect ratio for streams where aspect ratio information is not present in headers.

Thank you very much for finding and reporting this issue.


Leave a Comment

Please sign in to add a comment. Not a member? Join today