Integrated vs Discrete GPU while using IMSDK

Integrated vs Discrete GPU while using IMSDK

Hi,

My new desktop PC has a Intel Core i7 (precisely this one : http://ark.intel.com/products/65719/Intel-Core-i7-3770-Processor-8M-Cach... or tthis one : http://ark.intel.com/products/65523/Intel-Core-i7-3770K-Processor-8M-Cac...). As far as I know, this CPU embeds an integrated GPU (Intel HD Graphics 4000). However, the manufacturer chose to build the whole stuff using a discrete GPU (AMD Radeon HD7570).It seems in this case IMSDK cannot access integrated GPU resources : I cannot create a hardware session.

In this case, how can I use intel's hardware acceleration ? We consider using it for transconding applications (therefore, no need to render displayed decoded frames).

Thank you

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

You can still use HW acceleration via Media SDK on the Intel GPU while having discrete graphics card installed.

Just make sure that the Intel GPU is enabled in your BIOS and that you have recent Intel graphics driver installed.

The Intel GPU device should show up among your devices in the Windows control panel.

The Media SDK sample code supports finding the Intel GPU adapter even if it is not the primary adapter.

Some things to keep in mind:
- In case you are using Media SDK with DirectX9 you must have a monitor physically attached to the Intel GPU to activate the GPU. (some workarounds for this have been discussed in past forum posts)
- Media SDK with DirectX11 does not have this limitation. 

Regards,
Petter 

Hi Petter,

I have no option in my BIOS (uefi, this computer runs Win8) regarding GPU, and unfortunately, Windows does not show any Intel GPU in my system. Is there some hope ?

Regards,

Attachments: 

AttachmentSize
Downloadimage/png capture.png36.59 KB

Hi,

If there is no way of configuring UEFI (or BIOS) to enable Intel GPU I do not see a way for you to get access the to the GPU. For some unknown reason the PC manufacturer may have decided to not expose the Intel GPU in thier custom UEFI implementation.

You could contact the PC manufacturer directly and ask for support.

Regards,
Petter 

Hi Petter,

I finally managed to use GPU resources.

However, I am facing a new issue : sample_decode.exe can't instantiate any hardware IMSDK session. In fact, it worked for a few days, and does not work anymore now. I guess I broke dlls used by hardware sessions by installing some stuff on my computer.

Using the driver update utility, I tried to update my graphics driver, but it seems it is up to date (9.17.10.2849). 

At this point, I quite do not understand why this driver is the good one : my processor (http://ark.intel.com/products/65523/Intel-Core-i7-3770K-Processor-8M-Cache-up-to-3_90-GHz) is a third generation Intel Core i7, and the most recent Graphic driver available for download is the 9.17.10.3071 (https://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Desktop+graphics+drivers&ProductProduct=3rd+Generation+Intel%C2%AE+Core%E2%84%A2+Processors+with+Intel%C2%AE+HD+Graphics+4000&ProdId=3712&LineId=1100&FamilyId=39). However, neither the 9.17.10.3071 nor the 9.17.10.2932 driver are working on my computer. It seems these drivers are not designed for my hardware. I cannot find the 9.10.17.2849 driver to reinstall hardware libraries used by the IMSDK dispatcher.

Is the old driver still downloadable somewhere, or is there any hack to get the newest working ?

Thank you

Hi,

For 3rd generation Intel Core processor as yours I suggest using the latest driver available on Intel.com: 9.17.10.3071. 

Not sure why you're not able to use HW acceleration. I'm assuming you have verified that Intel HD Graphics device is active (a monitor also needs to be physically attached in case you use DX9. Not required for DX11/Win8).

Can you please share the log you get when executing the Media SDK tool, "mediasdk_sys_analyzer".

Regards,
Petter 

Hi Petter,

I do not know why it did not work before, but this time I managed to install driver 9.17.10.3071. It solved my issue, and I am now able to use hardware sessions with my computer. 

I enclose to screenshots (intel DDU website), one before driver update and one after. Is'nt it weird that two different versions of drivers are tagged as "current" at the same time ?

Thanks for your help.

Attachments: 

Hi,

The driver detection report is certainly confusing. It looks like the tool has some flaws. If you want, feel free to report this observation on the Intel graphics driver forum. The driver experts may be able to provide you details on how the reporting is done and/or fix potential issues.

Regards,
Petter 

Leave a Comment

Please sign in to add a comment. Not a member? Join today