I had connected a monitor to Intel Graphics adapter,but why "MFXVideoVPP_Init()" return MFX_WRN_PARTIAL_ACCELERATION?

I had connected a monitor to Intel Graphics adapter,but why "MFXVideoVPP_Init()" return MFX_WRN_PARTIAL_ACCELERATION?

My work computer has 2 display cards,the Intel HD4600 integrated card,and a NVIDIA's GT670 discreet card,I set all the cards are active in BIOS,and NV card is primary one.I connected a monitor to Intel integrated card,because the SDK's doc said to supporting hardware acceleration in a multi-gpu environment,the intel integrated gpu must be active and had a monitor connected to it;But I found in my program,whether I connect a monitor to intel gpu or not,the "MFXVideoVPP_Init()" always return "MFX_WRN_PARTIAL_ACCELERATION",what's the meaning of the warning? How can I catch hardware acceleration in a multi-gpu environment?

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Zheng,

Can you please provide the log output from the Media SDK 2013 R2 "mediasdk_sys_analyzer" tool. The log will possibly help identify the issue.

When observing the issue, are you running one of the Media SDK samples or your own application using the Media SDK API? Only for VPP?

Unfortunately, the "MFX_WRN_PARTIAL_ACCELERATION" status code is somewhat misleading. It means that HW acceleration is not used, instead the operation is using the SW implementation. 

Regards,
Petter 

Leave a Comment

Please sign in to add a comment. Not a member? Join today