Difference between SW and QSV encoded streams with Closed Captionning

Difference between SW and QSV encoded streams with Closed Captionning

Hi,

I'm using the Media SDK to encode some H264 streams with Closed Captioning mapped has SEI registered user data.

My issue is that when encoding with QSV I have some missing SEI messages.

The same test with the SW encoder gives all the expected messages.

I've attached two files. One, encoded using the SW encoder and the other one with the QSV encoder.

I've also attached the logs from the media SDK tracer.

Here is the log from sys_analyzer containing the information of my system:

Graphics Devices:
        Name                                         Version             State
        Intel(R) HD Graphics 4600                    10.18.10.3345       Active

System info:
        CPU:    Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
        OS:     Microsoft Windows 7 Enterprise
        Arch:   64-bit

Any idea on what could be the problem?

Thanks!

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Attachement!

Attachments: 

AttachmentSize
Downloadapplication/zip SW_and_QSV_0.zip645.69 KB

Hi Daniel,

Looking at the streams you provided I see the same stream layout for QSV and SW codec from a SEI perspective.

Can you explain in more details where you have identified the difference?  E.g. frame number, the missing SEI etc.

Regards,
Petter

Hi Petter,

I've uploaded two other streams where the difference could be seen easier.

The SW stream has H264_SEI_PT_USER_DATA_REGISTERED_ITU_T_T35 messages at:

P slices number 4, 7, 10 and 13 (in stream order) but the QSV stream doesn't.

Thanks!

Attachments: 

AttachmentSize
Downloadapplication/zip SW_and_QSV_1.zip5.71 MB

Hi Daniel,

Using Elecard Stream Analyzer, I do see one difference with the QSV stream, which is lacking SEI User Data SEI before the first B frame (following the second P frame, until the end of GOP), compared to the SW stream you supplied.

Can you please confirm that this is what you observe?

Regards,
Petter

Hi Petter,

With Elecard Stream Analyzer I can see the differences at the top fields of B slices #5 and #8, for instance.

However, before the first B slice, the QSV and the SW streams seem to have the same amount of SEI messages.

Thanks

Hi Daniel,

For some reason we are observing different things.

Using Elecard Stream Analyzer I see the first difference, with regards to UserData SEI, in slice #10 (first B slice following second P frame). Then the B-frame slice #16, #22 and so on.

Could you share some details about the part of your code which inserts the User Data SEI as Media SDK payload data? It would help us to try to reproduce the issue.

Regards,
Petter

Leave a Comment

Please sign in to add a comment. Not a member? Join today