No rules to build some samples

No rules to build some samples

I installed Media SDK successfully. Then I checked pre-built samples. Pre-built samples works fine. Now I'm trying to build samples myself.

I ran build.pl with recommended arguments (./build.pl --cmake=intel64,make,release --clean --build) (script worked without error) and then ran make command in __cmake/intel64.make.release directory. No errors, again. But when I view the contents of __cmake/intel64.make.release/__bin directory I see only libsample_rotate_plugin.so file and nothing else. I can see some files in the __lib directory. I want to find the sample_decode executable.

As I caught, there ara no build rules for some samples in automatically generated makefiles.

How can I build sample_decode sample?

14 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I'm sorry for a typo in the topic name. Can I edit it?

Hi Timopheny,

I believe you are using Linux to build your sample. There is an article written on Installing and running Intel Media SDK which can be helpful in your scenario. 
For Linux - https://software.intel.com/en-us/articles/installing-and-running-intel-media-sdk-2014-for-servers-on-linux
Let us know if I have got you right and you still have any questions.

Thanks,
Surbhi

That's okay!
There is an edit option on the top of the page. I am not sure if you will have that option.
I can change the subject for you, if you would like to.

-Surbhi

Hi, Surbhi,

Thank you for the quick reply!

I have the edit option only for my comments, not for the first post. It would be great if you change the subject, thanks.

Surbhi, you are right, I use Linux ubuntu server 12.04 (3.8.0-23-generic kernel).

Thank you for this article, but I've read Intel® Media Software Development Kit 2014 R2 for Linux* Servers Getting Started Guide
(Version 5.0.1603344.93446) and Intel® Media Software Development Kit for Linux* Servers Sample Guide. So I did everything according to article, you gave.

"./build.pl --cmake=intel64.make.release --build" command completed successfully ( [intel64.make.release State: OK] ). But when I view the contents of __cmake/intel64.make.release/__bin directory I see only libsample_rotate_plugin.so file and nothing else.

I tried to run "./build.pl --cmake=intel64.make.release" command and then to execute "make" command from __cmake/intel64.make.release directory. No errors occurred, but __cmake/intel64.make.release/__bin directory contained only libsample_rotate_plugin.so file again.

Do you think you could repeat this behavior?

If I execute "make" command from the __cmake/intel64.make.release/sample_decode dir, I see ''Nothing to be done for 'sample_decode/all'. And this is consisten with the Makefile content. May be I have some problems with Cmake? I have Cmake 2.8.7. Is it ok?

I looked at sample_decode/CMakeList.txt. There is a loop that checks drm, x11, ... variants (check_variant function is invoked). If neither one is configured, make_executable() function won't be invoked. In this case a makefile with empty "all" target will be generated (it's just my case).

So, why drm, x11, ... variants can be non-configured? As I caught, this variants must be configured by the parent CMakeList.txt. Why can it fail?

Hi Timophey,

It seems like there is some issue with installation and libdrm is not installed properly. Can you please verify your installation. After rebooting you can check if i915 module is installed correctly. Details about how to do and what to look for is mentioned in Getting started guide under verify correct installation.
If the installation is not configured properly, please reinstall the Intel Media SDK for Linux and also do no remove the drm which gets installed with the Media SDK Installation.
Hope this help. Please let us know your finding.

Thanks,
-Surbhi

I ckecked the installation.

Here is my lsmod | grep 'i915' result:

i915                     617480   1

drm_kms_helper   49196     1     i915

drm                     285862    2     i915, drm_kms_helper

i2c_algo_bit         13564      1     i915

video                   19652       2    i915, asus_wmi

/opt/intel/mediasdk/lib64/8086/0412/ content is:

libmfxhw64-p.so.1.10 libmfxhw64.so

Is it ok?

Thanks,

-Timophey

Hi Timophey,

I don't see any problem with your installations. I want you to check if CMake is able to access drm and x11 location and what permissions do you have. Another thing you can do it is to see if you are able to build the tutorials. you can download them from Media Solution Portal under tutorial section. Download the latest version on tutorials i.e. 0.0.3.
Here, you can see Makefile have LKFLAG and CKFLAG which checks and should throw a proper error. you can check for executable in the \mediasdk-tutorials-0.0.3\_build\<executable>.
Please let us know your findings.

Thanks,
-Surbhi
 

Hi Surbhi,

Thanks a lot for your support. I built samples from the tutorial successfully. There are lovely fresh binaries in the _build folder. Ready-made makefile works fine, so I think, I have some problems with cmake. I tried to use build.pl script with sudo but it didn't helps. As I discovered, there is a problem with PKG_LIBDRM_FOUND, PKG_LIBVA_FOUND and PKG_LIBVA_DRM_FOUND variables (cmake cache variables). They are all equal to "" (empty string). Now I'm trying to solve this problem. If you know, how these variables are set, let me know, please.

Thanks,

Timophey.

I haven't xServer. Is it a problem?

Hi, Surbhi,

I'm tired of repairing %%%% CMake code and just rewrote check_variant function in the mediasdk/builder/FindPackages.cmake source file. I removed PKG_LIBDRM_FOUND, PKG_LIBVA_FOUND and  PKG_LIBVA_DRM_FOUND variables check. I realize, that this is a dog-nail, but it helps to solve the problem and to build the samples. May be later, when I find out where these variables must be set, normal solution will be found.

Leave a Comment

Please sign in to add a comment. Not a member? Join today