iHD_drv_video.so init failed

iHD_drv_video.so init failed

HI
I run sample code of MediaSamples_Linux_5.0.1604371.71 on SDK2015ProductionEvaluation16.4 and CentOS 7
command is ./sample_multi_transcode_x11 -i::h264 ./ch06_720x480_9853F.dsp264 -o::h264 ./aa.264 -hw
It works normally on Intel Core i5-4570S CPU,but it does not work on Intel(R) Celeron(R) CPU  J1900
error message is ::
"Multi Transcoding Sample Version 5.0.1604371.71
libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva error: /opt/intel/mediasdk/lib64/iHD_drv_video.so init failed
libva info: va_openDriver() returns 1
terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc
Unrecognized device ID 0F31 (core dumped)"

Is "0F31" microcode of Celeron(R) J1900 ?
Is  Celeron(R) J1900 supported by media sdk 2015 support or not ?

 

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

The supported HW for Media Server Studio- 
Hardware: Intel Xeon® processor E3-1200 v3 product family and 4th Generation Intel Core™ Processor-based Platforms with Intel Iris™ Pro and Intel HD Graphics.
Media Server Studio doesn't support Celeron J1900 (BayTrail).

-Surbhi

Hi.

I am very eager to know whether NUC Kit NUC5CPYH celeron N3050 supports HW accelerated encoding or not?

Thanks.

I also get the problems libva error: /opt/intel/mediasdk/lib64/iHD_drv_video.so init failed, and I do not know how to address it.

Hi there, 

Can you provide the system and environment details along with the error?

Thanks,
Surbhi

Hi,

I recently acquired a Intel NUC DN2820FYKH with the Celeron N2830 CPU.

I'm trying to install and run Intel's Media Server Studio Essentials 2016 on it, using the gold OS, CentOS 7.1.1503.

But, after many trials I only get the following info:

libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva error: /opt/intel/mediasdk/lib64/iHD_drv_video.so init failed
libva info: va_openDriver() returns 1
vaInitialize failed with error code 1 (operation failed),exit
Unrecognized device ID 0F31

In some trials in Ubuntu 16.04.1 LTS the command vainfo return correct information, but I can not run the samples.

Can some one explain if the N2830 is really capable of using Intel Quick Sync? Is there anything else I need to do in order to get the QuickSync Working?

Thank you! 

Hi,

I just installed CentOS 7.1 1511 and MediaServerStudioEssentials2017 on a Intel NUC5CPYH (Celeron N3050).

The install script run without any error. But when I run vainfo I get:

libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva error: /opt/intel/mediasdk/lib64/iHD_drv_video.so init failed
libva info: va_openDriver() returns 1
vaInitialize failed with error code 1 (operation failed),exit

When I run ./sample_multi_transcode -i::h264 ../content/test_stream.264 -o::h264 test_out.h264 -hw -la I get:

Multi Transcoding Sample Version 7.0.16053497

libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva error: /opt/intel/mediasdk/lib64/iHD_drv_video.so init failed
libva info: va_openDriver() returns 1
libva info: VA-API version 0.99.0
libva info: va_getDriverName() returns 0
libva info: User requested driver 'iHD'
libva info: Trying to open /opt/intel/mediasdk/lib64/iHD_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva error: /opt/intel/mediasdk/lib64/iHD_drv_video.so init failed
libva info: va_openDriver() returns 1
error: failed to initialize VAAPI device

Does anyone was able to correctly install intel media on Celeron N3050? Intel's info says that recent Celeron with Intel HD Graphics are supported...

Thanks,
João

 

Hi João,

If you read the release note of the product, it says only support the 5 generation core up, so I am afraid the Celeron processor should not be supported.

https://software.intel.com/sites/default/files/media_server_studio_essen...

Mark

Leave a Comment

Please sign in to add a comment. Not a member? Join today