UMC_HEVC_DECODER::h265_exception in MFXVideoDECODE_DecodeHeader for HEVC video

UMC_HEVC_DECODER::h265_exception in MFXVideoDECODE_DecodeHeader for HEVC video

I have a 4K video file for which the first frame in the video seems to be a CRA frame. The NAL unit byte for the first slice is 0x2A. 

At the beginning of the buffer I pass to DecodeHeader I do pass the sequence header buffers (NAL unit bytes 0x40, 0x42 and 0x44), so the sequence header information should be complete. But in the debugger window, I see this twice for each DecodeHeader call:

First-chance exception at 0x7703c54f in graphedt.exe: Microsoft C++ exception: UMC_HEVC_DECODER::h265_exception at memory location 0x00229f04..

The original file is very big (400MB), so I copied the first 2MB to https://drive.google.com/file/d/0B9XDiCZCwCL7TFF5M1dKLVlEYlU/view?usp=sh... . 2MB should be enough to see why DecodeHeader fails.

I am running this on a i7 6th gen processor using the HW HEVC decoder plugin

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Silviu,

I am going to check it, which version of the media SDK are you using? Could I assume you run the sample_decode.exe at Windows platform?

Mark

I tried sample_decode from "Intel Media SDK Samples 2016 6.0.0.142" folder.

I have tried the older Media SDK 2014 and the newer "Intel(R)_Media_SDK_2016.0.2". Both of them seem to behave the same way. 

I am trying to run your content in our latest code with SKL hardware but got failed. I can parse your content with our VPA tool and it looks OK but I noticed this content is HEVC 10bit, I am trying to run it with 10bit setting now.

What is your command line when you got the failure?

Mark

Hi Silviu,

I can run the HEVC 10bit on the sample_decode now, but I still got error when parsing your content. I doubt if this is the case that you cut off the stream?

Could you try this on your side with the full file? 

You have to comment the following line to run HEVC 10 bit:

https://github.com/Intel-Media-SDK/samples/blob/master/samples/sample_de...

Mark

Leave a Comment

Please sign in to add a comment. Not a member? Join today