TensorFlow Optimization, gcc: error: ”-DEIGEN_USE_VML”

TensorFlow Optimization, gcc: error: ”-DEIGEN_USE_VML”

I'm following this https://software.intel.com/en-us/articles/tensorflow-optimizations-on-mo...

I get the error 

gcc: error: ”-DEIGEN_USE_VML” 

I suspect it is because I didn't do the steps

  • PATH can be changed to point to a specific version of GCC compiler:
    export PATH=/PATH/gcc/bin:$PATH
  • LD_LIBRARY_PATH can also be changed to point to new GLIBC :
    export LD_LIBRARY_PATH=/PATH/gcc/lib64:$LD_LIBRARY_PATH.

But how does one do these? What specific version of the gcc compiler? And what is "new GLIBC"? Where does one get that?


2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Best Reply

I got it working. I tried dozens of things, so it's hard to say what fixed it. I'm guessing upgrading gcc did it.

Also, I had to do

export PATH=~/bin/:$PATH


Leave a Comment

Please sign in to add a comment. Not a member? Join today