How to make Composer not inlining?

How to make Composer not inlining?

I tried /Qinline-max-size=0. The message during compilationwas

icl: command line remark #10148: option '-Qinline-max-size' not supported

It looks like non of /Qinline- options are supported.

Intel C++ Compiler for applications running on IA-32, Version 11.1 Beta Build 20081208 Package ID: composer_beta_update3.040

Copyright (C) 1985-2008 Intel Corporation. All rights reserved.

-Vladimir
6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Vladimir,

Yes, you're correct. The /Qinline-* options are disabled in Composer (mainstream product). Hope that helps, but please let me know if you need any further clarification, thanks.

-regards,
Kittur

Hi Kittur,

Thanks for the answer.
In this case it's confising since there is no information in Releas Notes that inline is not supported,while the Compiler UserGuide that goes with Composer claimes it is.

-Vladimir

Thanks Vladimir. I'll look into the user guide and if that's the case, then I'll file an issue with the docs team to fix, appreciate much.
-regards,
Kittur

Hi Vladimir:

I usually use /Ob0, which disables inlining.

Also, Intel compiler should support: -fno-inline-functions

Does that help?

Regards,
MrAnderson

Quoting - MrAnderson (Intel)
Hi Vladimir:

I usually use /Ob0, which disables inlining.

Also, Intel compiler should support: -fno-inline-functions

Does that help?

Hi David,

Thanks for reply.
-fno-inline-functions option is not supported by Composer.
But /Ob0 works fine. Thanks again.

-Vladimir

Leave a Comment

Please sign in to add a comment. Not a member? Join today