The first bug :(

The first bug :(

I recently installed visual studio 2010 and parallel studio 2011 beta.

First i updated my old Intel C++ project to 2010. After a litte modification in linker (and replace old tbb dll's(which is came from intel c++ compiler 11.65),).

After i tried to launch isapi extesion. Then bammmm. The iis process is crashed :(.

after a litte modification. I changed isapi extension startup code with

} catch(sql::SQLException &e) {
FILE* f=fopen("C:\\\\err.txt", "a++");
fprintf(f, "%d %s", e.getErrorCode(), e.what());
} catch(...) {
FILE* f=fopen("C:\\\\err.txt", "a++");
fprintf(f, "aa");
return FALSE;

Then i catch the error. The problem is mysql connection but isn'tsql::SQLException. It catch ... !!! I think it gives a memory error. (something like in debugger: 0xC0000005)

it was something like

register sql::Driver* driver;
if (!driver) {
FILE* f=fopen("C:\\\\err.txt", "a++");
fprintf(f, "no driver");


when i calldriver->connect(connection_properties); the application is crashed.

Now, i cannot back to VS 2008 because the new composer deleted old intel c++ integeration (but i wasn't select vs 2008 integration in Parallels studio). I back to old isapi dll (which is compiled by old compiler), it works fine!!!.

I just hated because my old Visual Studio 2008 has gone!!!, The parallel is deleted old integration, and I didn't selected visual studio 2008 integration in parallel's studio setup. :(

So i just can't update the site. :(:(:(

platform x64.

mysql client liblary 5.5

mysql c++ liblary: 1.0.5

tbb: switched 3 from 2.

is there a easy command to get old visual studio 2008, intel c++ compiler integration?

Some Screenshots:

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Best Reply

Hi Burak,

To restore your original Parallel Composer integration into Visual Studio 2008*, you should be able to do the following:

  1. Go to Control Panel->Add/Remove Programs
  2. Click on original Intel Parallel Composer entry and click Change/Remove button
  3. Click "Modify" and continue
  4. Make sure that the IDE Integrations into Microsoft Visual Studio and Parallel Debugger Extensions are selected to be installed
  5. At the next screen, only check Microsoft Visual Studio 2008* to integrate into
  6. Continue with installation

Let me know if that works. I believe that removing the old integration is an installation issue, and I'm following up on that.

For the other issue with the application crash, are you starting the application from the Visual Studio 2010* IDE (i.e. via Start without Debugging)? If so, go to the project properties, and under "Configuration Properties", select "Intel Debugging" and
change the field value "Parallel Debug Environment" from "Auto" to "Disabled". I don't know if this is causing the problem you're experiencing, but there is a known issue caused by this that I want to rule out. If you still get the crash, we'll likely need more information to investigate. Let us know if it will be possible to send us a reproducible test case. Thanks.

Thanks, i was did your old post. Now i can use visual studio 2008 with old Intel C++ compiler. (i can compile the old project, but when i try to intel c++ options dialog in vs 2008 it crash but its really not a problem, i just cannot open new project for intel c++ i will format my server when we will move the server).

I will try that i hope if it will work, now i am trying my other works.

i love intel's support. Thank you!! just thank you.

Have a nice day, Thank You


edit: i reinstalled Intel C++ compiler's visual studio(clicked modify, then selected vs 2008 integration) integration. Still i have say thank you.

edit2: i disabled Parallel Env. in Intel Debug option. The dll still gives same error. I can give administrator password of my server. If the problem is about the compiler. Just contact me at e mail ( thank you.

Leave a Comment

Please sign in to add a comment. Not a member? Join today