mcpcom not found - wrong directory paths

mcpcom not found - wrong directory paths

Hi!

I have just downloaded and installed Intel Parallel Studio 12 beta on my Ubuntu 10.04 amd64 machine.

However when I tried to compile my test program:

$ which icc
$ which mcpcom

$ /opt/intel/bin/icc helloworld.c
mcpcom: No such file or directory
compilation aborted for helloworld.c (code 100)
$

It seems that the installed has stuffed up the directories!

How can I get it working agian?

Thanks!

Mark

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Have you set the intel compiler environment before you compile your case?
You may call the following command to set the env:
$ source /opt/intel/bin/compilervars.sh intel64

Thanks! It works now. Do I have to call this line every time when I open the new terminal?

Also would it be a good idea for the installer to remind people to run this line before they use the compiler?

Yes. You will have to set icc environment when you open a new terminal window. If you don't want to do this, you may add the environment setting command in your profiler so that it will automatically executed for each new terminal window.

Leave a Comment

Please sign in to add a comment. Not a member? Join today