Parallel inspector giving wrong line number

Parallel inspector giving wrong line number

Hi

After using parallel inspector,the log shows errors
but when i double click to see source its giving wrong line number

sometimes there will not be any code present at the line shown by inspector

here are the VS2005 compiler settings

/Od /I "..\..\base-libs\Codebase\5.1mt" /I "." /I "Xmam" /I "Custlist" /I "RepObj" /I "Repobj\Bison" /I "Repobj\Bison\nt" /I "Arobject" /I "..\..\..\TAO\TAO-1.5\ACE_wrappers\TAO" /I "..\..\..\TAO\TAO-1.5\ACE_wrappers\TAO\orbsvcs\orbsvcs" /I "..\..\..\TAO\TAO-1.5\ACE_wrappers" /I "..\..\..\TAO\TAO-1.5\ACE_wrappers\TAO\orbsvcs" /I "C:\opt\SmartHeap_8.00smp_x86\include" /D "WIN32" /D "_DEBUG" /D "_CONSOLE" /D "__WINNT__" /D "__ALL_H_INCLUDED__" /D "_VC80_UPGRADE=0x0600" /D "_UNICODE" /D "DP" /D "I2_TAO_WIN32" /D "_CRT_SECURE_NO_DEPRECATE" /D "NLM_CERT" /D "USER_FUNC" /D "DOUBLES_ONLY" /D "__USECDX__" /D "__CONFIG_REQD__" /D "WAN_OPTIMIZE" /D "TRIMED_HEXPR" /D "__ERROR_LOGGING__" /D "S4FOX" /D "S4WIN32" /D "S4DEBUG" /D "S4OFF_OPTIMIZE" /D "S4OPTIMIZE_OFF" /D "__FYI_CONTROL__" /D "__FOR_INTEL_BMK__" /D "__FOR_INTEL_MEM__" /D "__EXPORT__" /D "__FOR_COMPAQ__" /D "DB_OPT" /D "COMPDECOMP" /D "_VIS_NOLIB" /D "__LICENSE_LIB__" /D "__SMARTHEAP__" /D "_WIN32_WINNT=0x500" /FD /EHsc /MD /Zp4 /Yu"types.h" /Fp".\release/plannts.pch" /Fo".\release/" /Fd".\release/" /FR".\release\" /W3 /nologo /c /ZI /TP /errorReport:prompt /vmg /w

any suggestions/help

from
nayeem khan

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Quoting - khan_069
Hi

After using parallel inspector,the log shows errors
but when i double click to see source its giving wrong line number

sometimes there will not be any code present at the line shown by inspector

here are the VS2005 compiler settings

/Od /I "....base-libsCodebase5.1mt" /I "." /I "Xmam" /I "Custlist" /I "RepObj" /I "RepobjBison" /I "RepobjBisonnt" /I "Arobject" /I "......TAOTAO-1.5ACE_wrappersTAO" /I "......TAOTAO-1.5ACE_wrappersTAOorbsvcsorbsvcs" /I "......TAOTAO-1.5ACE_wrappers" /I "......TAOTAO-1.5ACE_wrappersTAOorbsvcs" /I "C:optSmartHeap_8.00smp_x86include" /D "WIN32" /D "_DEBUG" /D "_CONSOLE" /D "__WINNT__" /D "__ALL_H_INCLUDED__" /D "_VC80_UPGRADE=0x0600" /D "_UNICODE" /D "DP" /D "I2_TAO_WIN32" /D "_CRT_SECURE_NO_DEPRECATE" /D "NLM_CERT" /D "USER_FUNC" /D "DOUBLES_ONLY" /D "__USECDX__" /D "__CONFIG_REQD__" /D "WAN_OPTIMIZE" /D "TRIMED_HEXPR" /D "__ERROR_LOGGING__" /D "S4FOX" /D "S4WIN32" /D "S4DEBUG" /D "S4OFF_OPTIMIZE" /D "S4OPTIMIZE_OFF" /D "__FYI_CONTROL__" /D "__FOR_INTEL_BMK__" /D "__FOR_INTEL_MEM__" /D "__EXPORT__" /D "__FOR_COMPAQ__" /D "DB_OPT" /D "COMPDECOMP" /D "_VIS_NOLIB" /D "__LICENSE_LIB__" /D "__SMARTHEAP__" /D "_WIN32_WINNT=0x500" /FD /EHsc /MD /Zp4 /Yu"types.h" /Fp".release/plannts.pch" /Fo".release/" /Fd".release/" /FR".release" /W3 /nologo /c /ZI /TP /errorReport:prompt /vmg /w

any suggestions/help

from
nayeem khan

Looks like you are analyzing the release version of the code, even you disabled the optimization by using /Od. Try to add /DEBUG option here, or switch to debug mode (for linking with debug versions of the libraries).

Which Inspector Update you were using?

Generally, we don't suggest you use optimization features when you are debugging a developing project. It is better to optimizate your project after building successfully.

Thanks,
Wise

Leave a Comment

Please sign in to add a comment. Not a member? Join today