Having trouble installing Parallel Studio on Windows 7

Having trouble installing Parallel Studio on Windows 7


I'm having trouble installing Parallel Studio on Windows 7. The setup executable I'm using is parallel_studio_sp1_setup. I get to the Installation Options - Choose installation type page. Once I select either full or custom install I get an error dialogue box:

Invalid Directory C:Program Files (x86) Access is denied

I'm installing as administrator. When theParallel Studio setup executable first starts there's a prompt from Windows to approve changes to the system from this executable.(Which I approve.)

I've just started using Windows 7 so possibly/probably it's something dumb on my part I haven't configured properly.

All very frustrating as I have some genomics code which I'm very keen to get stuck into optimising for multi- cores

Anyone had this problem and solved it?



3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I might have fixed it so I thought I'd post what I did for anyone else with teh same problem. If you right-click on the Parallel Studio setup executable you get a number of choices for running the exe. I chose "Trouble shoot compatibility" which after a selection or two had the exe running in an XP mode. The setup wizard went through its stuff with no reported errors.

As I've started MSVS2008 and I'm now apparently running the genomics executable with Parallel Studio profiling enabledthings look a bit more positive positive.

I can just tell that given I'm running someone else's code, ported from Linux to Windows, using MSVS2008 (new edition to me),on a new OS (Windows 7) ...this is going to be a white knuckle ride for the next few months :)

Ahhh ... if it was easy it wouldn't be fun!


Thanks for sharing your fix, David. We really appreciate that!

Aubrey W.
Intel Software Network Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today