hang on startup -- wshtcpip.dll

hang on startup -- wshtcpip.dll

I am attempting to analyze my application using Intel Inspector but my app seems to hang. Each time it stops on this module: Loaded module: C:\\Windows\\System32\\wshtcpip.dll, address range [0x000007FEFC720000-0x000007FEFC726FFF], minimal analysis

I can see my app's process in task manager but it never starts. I'm using Inspector to look for memory errors. I'm inspeciting at the minimum level and it still hangs at startup.

My OS is Windows 7 Pro x64. Using VS2008. The app is a Windows MFC app that's 64bit. What steps do I take to debug this problem?

NOTE: I ran 'sfc /SCANFILE="C:\\Windows\\System32\\wshtcpip.dll"' as well as 'sfc /scannow' to ensure there is no sort of file integrity (damaged or virus) issues. Both checks passed.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

"What steps do I take to debug this problem?"

Well, have you run Inspector on the sample application that is included in the product? Any problems with that?

Also, can you build a simple app that loaded that DLL and demonstrates the same problem?

Sorry for the delay in reply. I ordered the full version and wanted to wait and try it with the complete version first. Still having the same problem on one of my projects.

I did try using the sample projects. No problems there. I don't think I can build a simple app that demonstrates the issue. My project is a rather large Win32 application. I have no idea as to the root cause so re-creating the issue would be rather difficult.

Where do I go from here? Is there a priority support option I can pay for?

So, running the sample demonstrates that the technology works on your system, i.e., no installation problems. Thus, the problem is probably application-specific. Since the problem seems to be related to wshtcpip.dll, I was hoping for a sample app that loads this DLL. The web description that I found says it is helper functions for Windows* Sockets.

I tried building some sample WinSock apps, but wshtcpip.dll did not get loaded. :(

Leave a Comment

Please sign in to add a comment. Not a member? Join today