PS 2011 installation - windows installer service

PS 2011 installation - windows installer service

Hi,When installing Parallel Studio 2011 (integrating with vs2005 & vs2010) on Win XP SP3, full install, and on "processing package 11 of 31" / configuring installer, I get an error window saying: "Error while installing package C:\\...\\Composer\\Installs\\1033\\w_composerc_ide_unique_p_12.0.063\\w_composer_ide_unique_p_12.0.063.msi" The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed."I updated the Windows Installer to version 4.5, but the same error occurred.Any clues on how to proceed?

Much thanks,Chris

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Some more information:I successfully installed the amplifier, inspector, and advisor, then tried the composer by itself. Same error. Will continue messing with it, but if anyone has clues on this, please let me know.Thanks again,Chris

Some web references indicate this problem could be due to a corrupt or unstable windows installer service rather than a problem with the underlying application being installed. One reference suggesed the following that might help:

  • Log on to your computer as an administrator.
  • Click Start, and then click Run.
  • In the Open box, type cmd, and then click OK.
  • At the command prompt, type msiexec.exe /unregister, and then press ENTER.
  • Type msiexec /regserver, and then press ENTER.

The page at has two other suggestions that you may want to try and see if they help.


Unfortunately this did not work for me. The tips on winhelponline didn't work either... perhaps I need to drop back to an earlier version of Windows Installer or something.

It's curious that Inspector, Amplifier, and Advisor install but the Composer does not. There have been product updates since you encountered this issue. Can you try the latest version of IntelParallel Composer (update 2, posted Jan 20, 2011) andsee if the problem is resolved?


Leave a Comment

Please sign in to add a comment. Not a member? Join today