"Error: Can't find application to launch"

"Error: Can't find application to launch"

Hi, I was wondering if someone could help me with this. I have two executables I can run, one benchmark suite and one unit test suite. When I run parallel amplifier on the unittest suite, it works as expected. However, when I run it on the benchmark suite I get the error message 'Error: Can't find application to launch: F:\\Myproj\\app.exe' in my parallel amplifier messages window.I can't find any documentation on this error message, and I'm totally baffled by the different behaviour between my two executables. They follow very similar structures (a working directory, relative path application location, and some command line args)Thanks, Matt

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I've seen this issue reported before, but it's been fixed some time ago.

Are you using the beta or product of Intel Parallel Studio 2011?

Jennifer

The app project is built with Intel Parallel Composer, right?
Which VS? the version of Amplifier &Composer?

Jennifer

Hi Jennifer, The app is built via an ant build script, using the Intel 11.0.67 compiler. This build is for vs2008, SP1. The versions of amplifier and inspector are:Intel Parallel Amplifier Update 2, (build 76442), Copyright 2008-2009 Intel CorporationIntel Parallel Inspector Update 2, (build 75522), Copyright 2008-2009 Intel CorporationMatt

You probably mean 11.1.067 for the compiler.

If the app is built with a script, can you run it within VS2008by press [F5] or [ctrl+F5]?Let's make sureit's setup correctly within the VS env first.

If yes to above,try to upgrade to the Intel Parallel Studio 2011 that is the next version of Intel Parallel Studio. You can get a free upgrade if you've got the Intel Parallel Studio - http://software.intel.com/en-us/articles/intel-parallel-studio-2011-upgrade/.

Let me know how it goes and thanks,

Jennifer

Yes, sorry I did mean 11.1.067.The application runs fine in visual studio with F5 and ctrl+f5. It also runs fine from the raw command line.I upgraded to parallel studio 2011, and still get the same behaviour

Error: Can't find application to launch: F:projectstrunkprojectbinvc9x64_releasebenchmarks_x64_release.exe.

Also, I can still run amplifier on the unit tests with the expected results.Thanks, Matt

I found the solution, there was a lone space ' ' at the end of my 'Command' argument in the visual studio properties page. While visual studio is fine with this, it confuses parallel studio. (should I do a bug report or something?)Thanks for your help, Matt

Thank you for posting the root cause and solution here.

It's not necessary to report to Intel Premier Support. I can file the bug directlybased on this thread.

Let me try to duplicate it first. If I have any more questiion, I'll ask here.

Thank you again!
Jennifer

Please try VTune Amplifier XE 2011 Update 3 to avoid this.
(Intel? Parallel Amplifier 2011 Update 2 still has this problem)

Leave a Comment

Please sign in to add a comment. Not a member? Join today