Long compile time and low execution speed

Long compile time and low execution speed

Hi,

I'm using VS2005 together with Parallel Studio 2011 Update 1. When I compile my software projects with the Microsoft compiler, I have acceptable compilation time and an execution time of 2.9 secs. In the case of the Parallel Composer, however, it takes ages to compile and the execution speed is even lower (3.6 secs) than with the Microsoft compiler. In both cases, the compilation was carried out with /O2 compiler switch and my projects make use of OpenMP.

Am I doing something completely wrong or how is this explainable? And how can I solve the issue?

Cheers,
Thomas

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Thomas,
is /GL (/Qipo) on? It's likely the reason.
is it possible to send us the code using Intel Premier Support - https://premier.intel.com/ ? Or through private response.

Remove /GL to see if the compilation is faster.

The performance: make sure only ONE openmp runtime is running. The Intel C++ Compiler's openmp runtime is compatible with VC's. So you only need to link in the intelc's openmp runtime. See this article for some intructions- http://software.intel.com/en-us/articles/how-to-use-intelr-compiler-openmp-compatibility-libraries-on-windows/

Jennifer

Hi Jennifer,

thanks for your response. Unfortunately, both /GL and /Qipo were not enabled in my solution, so there must be a different reason for that.
Do you have any other suggestions?
My current compiler settings as displayed by VS are
/c /O2 /I "../../" /D "UNMANAGED_EXPORTS" /D "_CRT_SECURE_NO_DEPRECATE" /D "_VC80_UPGRADE=0x0710" /D "_WINDLL" /D "_MBCS" /EHsc /MD /GS /fp:precise /Fo"Release/" /W3 /nologo /Wp64 /Zi /Qopenmp

Thomas

Leave a Comment

Please sign in to add a comment. Not a member? Join today