Problems Integrating with VS2010

Problems Integrating with VS2010


I'm trying to install Parallel Studio XE 2011 and integrate with VS2010 Ultimate.
I've run the installer (tried as user and as admin, no difference) and it partially integrates - Intel C++ Composer XE Help is present, but nothing else, no toolbars, no Project-> options, nada. After reading earlier posts I checked C:\\Program Files (x86)\\MSBuild\\Microsoft.Cpp\\v4.0\\Platforms\\x64 and Win32 and nothing has been added here. Guessing that's at least a symptom of the problem.

Any clues?


8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Is the problem with
VS2010 integration only? Can you use standalone GUI of Intel Inspector XE or
Intel VTune Amplifier XE? If so, try to disable/enable VS2010
integration manually:

VTune Amplifier XE:

In the install
directory like C:\Program Files (x86)\Intel\VTune Amplifier XE 2011\bin32 there is amplxe-vsreg.exe. Run it in command

get help:
amplxe-vsreg.exe --help

disable integration:
amplxe-vsreg.exe -d 2010

enable integration:
amplxe-vsreg.exe -i 2010

Inspector XE:

C:\Program Files
(x86)\Intel\Inspector XE 2011\bin32

inspxe-vsreg -d 2010

inspxe-vsreg -i 2010

Composer XE
integration can be changed through usual Uninstall program -> Modify ->
remove or set MS VS2010 integration.

I don't have VTune or Inspector, so no dice there. Did as you suggested and add/remove the VS integration from the setup, still no joy and still get the "There are no Intel C++ compilers installed" message.

Had a thought, though, is it possible that this is what I would see if only the IPP libraries had been purchased?

Are you trying to install Intel Composer XE only, as a standalone product? Or you're installing Parallel Studio XE with only "Composer XE" component selected?In your case I assume problem is that the Intel Compiler is not installed at all, not just VS2010 integration.Yes, the license issue is possible. If it's only for IPP, this can lead to absence of compiler. We should check your license to see which products are covered with it. I'll contact to licensing guys for this.

OK, this is really becoming a problem now. I can't even run the IPP sample application. Help!

Hello Andy,

Since the IPP library is a passive component, it is a library you link against, the integration with Visual Studio is fairly simple. You should find help for the IPP library integrated into Visual Studio and, in the case of VS2010, you should be able to set a "USE_IPP" property in your solution/project files.

I'm assuming you have downloaded and installed the IPP sample files from here:

If so, make sure they are installed into a writeable location on your system, such as:


and then open up a project that includes a VS2010 solution file, such as the ipp_compress project:


Within that solution file, right click the default ippcompress project and choose properties. On the properties page, under "Configuration Properties,"you should see and "Intel Performance Libraries" option that includes a "Use IPP" property (yes/no). If you see this then IPP is "integrated" into VS2010.

Toggling the setting above between "yes" and "no" should toggle a definition on the compiler command-line. For more information on that command-line option, see this article:

Please be sure your IPPROOT environment variable is set, the sample solution files depend on that environment variable being defined. Also, the VS2010 project files have been hard-coded and may require some tweaking to make that "Use IPP" element to work; however, for any new project you create from scratch the "Use IPP" should work as expected.

Here's a screenshot of what I mean by the "Use IPP" property:

Hope this helps,


p.s. For a sanity check, the samples also include build scripts that can be run from the command-line. Please try running some of those to see if they work. All they require is that your IPPROOT environment variable is set AND that you saved the samples into a directory preserving the "...\ipp-samples\..." part of the name.

p.p.s. For support questions on IPP, also check out the IPP forum and the IPP KB.

OK Chaps, this seems to work. I'm actually using C# and I've used the samples to create a working application (despite the fact that the Wavelet sample application throws an exception on startup... :-) )

All is now good, as long as one completely disregards the 'Getting Started' tutorial that installs with the software.

Thanks for your time,



Yes, those instructions are for VS2008 and prior. Everything changes with VS2010. Bug has been filed to get that fixed.


Leave a Comment

Please sign in to add a comment. Not a member? Join today