Error detected during analysis

Error detected during analysis

  • I have Parallel Studio Update 2 installed on an Intel quad core PC with Windows 7 (32bit).
  • I have gone through the tutorials for Parallel Inspector.
  • The command line indicates the version is "Intel Parallel Inspector 2011 Update 2 (build 140245)"
  • I am trying Inspector on our software and all I get is "Error detected during analysis"
  • Is there any log information that can point to why I'm having the failure?

This is a complicated software project. I am using Visual Studio 2010 sp1. The solution has a mix of 45 projects including C++, C# and ATL COM. There are about 625,000 lines of code. I'm not sure if Parallel Studio can even handle such a large project.

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


To see
if we can narrow the scope of the behavior can you provide the following

- Is
this a new installation of Intel Parallel Inspector 2011 or existing install? If existing, has Parallel Inspector 2011
previously analyzed your application successfully?

- Along
similar lines, is your Parallel Inspector installation able to successfully analyze
other applications like a sample application that comes with the product such
as Tachyon?

- When
the analysis fails, does it fail each and every time in the same way (persistent
/ consistent)?

- Which
Inspector analyzes are you running? Can
you provide the command line being ran?
You can obtain the command line by clicking on the Show Command Line
button lower right hand of the Parallel Inspector GUI.

- Do
other analysis types work? For example, a
simple Detect Leaks.

- Does your
application run from beginning to end outside of Parallel Inspector?


- This is a new install of Intel Parallel Inspector 2011.

- Inspector successfully analyzed the sample application tachyon_studio.

- For my large applicationInspector fails every time (tried 8 times) and it fails right away.

- The command line indicates the version of Inspector I am running is "Intel Parallel Inspector 2011 Update 2 (build 140245)". I can't find a "Show Command Line" button in VS2010. I'm looking on the Inspector Results tab that includes the "Collection Log" and "Summary". Instead I brought up a separate command window (cmd.exe) in administrator mode, navigated to the Inspector directory and issued the version command to get the version.

- None of the Inspector analysis types work at any level. I've tried Memory and Threading at all three levelsand they all fail.

- My application does run from beginning to end outside of Inspector. It is an existing applicaiton that has been shipping to customers since 1993 but in recent years the application has had many threads added. The version I am testing with Inspector is a shipping product to the field.

Just before the analysis failure I get an "Application Error" dialog that I don't get outside of Parallel Studio that says "The application was unable to start correctly (0x80000003). Click OK to close the application."


The Inspector uses the Visual Studio "Debugger" configuration to launch your application. If you press F5, does your app run correctly? If not, then Inspector won't be able to run it, either. :(

Also, you say you are testing the "shipping product." Are you running Inspector on the Debug build of your application? (Note: make sure you set "Basic Runtime Checks" to Default, since otherwise the generated checking code fools our checking code. :\ )

The application does run correctly when I press F5.

To be more clear, I am using the code base of a shipping product. I have compiled all of the projects that make up that code base in Debug mode.

Thank you for the clarification.

At this point, we are going to need to have you provide us with some files. The best (and secure) way to do that is via Intel Premier Support. It is free to registered eval and paying customers. Please zip up the results directory for one of the failed runs and attach it to the issue.

I am trying to login to Premier Support but having some trouble. My support isn't supposed to expire until October 01, 2011. I've emailed to try find out what is going on.

Leave a Comment

Please sign in to add a comment. Not a member? Join today