Unable to open C++ project: MSBuild does not contain value for the VCTargetsPath

Unable to open C++ project: MSBuild does not contain value for the VCTargetsPath

I installed VS11 developer preview and since then I cannot open C++ projects in VS10: the error I get is as follows:error : MSBuild does not contain a value for the "VCTargetsPath" property.The trouble is, uninstalling '11 doesn't solve the issue, so I'm looking for your help here.Thanks,Dmitri

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hello Dmitri,

I think this question should be addressed to Microsoft, since Intel tools are not involved in your problem.


I have the same problem. Were you able to find a solution to get your projects working again?

I have 3 versions ofVisual Studios ( 2005, 2008 and 2010 )installed ondevelopment and testcomputers
and all of them work without affecting each other:

- Try to contact Microsoft;

- Try to check 'SET' and 'PATH' environment variables from the command line;

- Try to review 'VS 2010 & VS 2011' -> 'Tools' -> 'Options' -> 'Projects and Solutions' settings;

- Did you convert your projects from 'VS 2010' to 'VS 2011'? If Yes, you won't be able to open them in 'VS 2010';

Note 1: Always try tocreate backups during a solution & projectconversion process.

Note 2: It really could be a Microsoft's bug.

Best regards,

No, I'm afraid I didn't, so I opted for a total reinstall. I think the issue is that VS2011 somehow messes up the Target files. This, coupled with a very un-clean installation procedure of VS2011, has resulted in basically unusable C++ on my system. Oh, and this has nothing to do with project conversion because it happens even on newprojects.That should teach me for running early builds in non-VM environments. :)

So, you didn't try to Repair the installation, right?

We made a hard decision to stay with VS 2005 and VS2008 as longer as we could. There are some
problems with VS 2010 and I can see that VS 2011 is getting worse!

Best regards,

Leave a Comment

Please sign in to add a comment. Not a member? Join today